Bug 481089 - trashapplet grabs all cpu at desktop startup
trashapplet grabs all cpu at desktop startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 22:48 EST by Jens Petersen
Modified: 2009-01-22 22:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 22:17:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-01-21 22:48:50 EST
Description of problem:
Trashapplet seems to be doing something funny at desktop startup?

Version-Release number of selected component (if applicable):
gnome-applets-2.25.4-1.fc11

How reproducible:
100%

Steps to Reproduce:
1. login to latest rawhide gnome desttop
  
Actual results:
No panels appear until one pushes Alt-F1
CPU is at 100% by trashapplet.

Expected results:
panels to appear normally.

Additional info:
Backtrace without debuginfo:

#0  0x007c6359 in g_slist_find () from /lib/libglib-2.0.so.0
#1  0x007d1bba in g_once_init_enter_impl () from /lib/libglib-2.0.so.0
#2  0x00176938 in panel_applet_get_type () from /usr/lib/libpanel-applet-2.so.0
#3  0x00176bef in panel_applet_factory_main_closure ()
   from /usr/lib/libpanel-applet-2.so.0
#4  0x00176d8b in panel_applet_factory_main ()
   from /usr/lib/libpanel-applet-2.so.0
#5  0x0804b6e6 in gtk_progress_bar_set_text ()
#6  0x00c60735 in __libc_start_main () from /lib/libc.so.6
#7  0x0804b131 in gtk_progress_bar_set_text ()
Comment 1 Jens Petersen 2009-01-22 22:17:06 EST
Seems to be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.