Bug 481102 - yum-rpm-warm-cache breaks refreshing update list and adding or removing software in KPackageKit
yum-rpm-warm-cache breaks refreshing update list and adding or removing softw...
Status: CLOSED DUPLICATE of bug 485042
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 00:43 EST by SonicGTR
Modified: 2014-01-21 18:07 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-28 08:55:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SonicGTR 2009-01-22 00:43:17 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

When attempting to look for a program in the Add or Remove Software section I get an error message. The same error message is displayed when attempting to refresh the Check And Install Updates section.

Reproducible: Always

Steps to Reproduce:
1. Select System Settings from the list of applications
2. Select Add And Remove Software in the Computer Administration section
3. Search for programs or updates.
Actual Results:  
An error message is displayed:

A problem that we were not expecting has occurred.
Please report this bug with the error description.

Error Type: Error Value: 'NoneType' object is unsubscriptable File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2280, in main() File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2277, in main backend.dispatcher(sys.argv[1:]) File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 600, in dispatcher self.dispatch_command(args[0], args[1:]) File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 567, in dispatch_command self.search_name(options, searchterms) File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 327, in search_name self._check_init(lazy_cache=True) File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1965, in _check_init self.yumbase.repos.doSetup() File : /usr/lib/python2.5/site-packages/yum/repos.py, line 71, in doSetup self.ayum.plugins.run('postreposetup') File : /usr/lib/python2.5/site-packages/yum/plugins.py, line 178, in run func(conduitcls(self, self.base, conf, **kwargs)) File : /usr/lib/yum-plugins/rpm-warm-cache.py, line 32, in postreposetup_hook cmd = commands[0] 

Expected Results:  
It should have looked for the packages or updates that are installed or are available.

I'm new to Linux-based operating systems, so I'll probably need step-by-step instructions if fixing this bug involves using Konsole.
Comment 1 Steven M. Parrish 2009-02-04 06:40:24 EST
Based on the output this appears to be a problem with PackageKit itself not the kpackagekit gui.  Reassigning to Packagekit.
Comment 2 Richard Hughes 2009-02-04 07:09:24 EST
You need to remove yum-rpm-warm-cache -- it's broken.
Comment 3 Kevin Kofler 2009-02-04 08:12:17 EST
Reassigning to yum-utils.
Comment 4 seth vidal 2009-02-04 11:41:15 EST
what ver of yum-utils/yum-rpm-warm-cache is this?
Comment 5 Thomas Spura 2009-02-28 07:52:49 EST
Here is the same problem:

after running a "yum update" or "yum install " + somepkg, a SIMILAR error is displayed

Error Type: <type 'exceptions.TypeError'>
Error Value: 'NoneType' object is unsubscriptable
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2314, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2311, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 600, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 508, in dispatch_command
    self.get_updates(filters)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1768, in get_updates
    self._check_init()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1995, in _check_init
    self.yumbase.repos.doSetup()
  File : /usr/lib/python2.5/site-packages/yum/repos.py, line 71, in doSetup
    self.ayum.plugins.run('postreposetup')
  File : /usr/lib/python2.5/site-packages/yum/plugins.py, line 178, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File : /usr/lib/yum-plugins/rpm-warm-cache.py, line 32, in postreposetup_hook
    cmd = commands[0]

Version:
yum-utils-noarch-1.1.19-1.fc10
yum-rpm-warm-cache-noarch-1.1.19-1.fc10
Comment 6 seth vidal 2009-02-28 08:55:25 EST

*** This bug has been marked as a duplicate of bug 485042 ***

Note You need to log in before you can comment on or make changes to this bug.