This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 481124 - incorrect search highlighting
incorrect search highlighting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Preethi Thomas
:
Depends On:
Blocks: 457073
  Show dependency treegraph
 
Reported: 2009-01-22 04:31 EST by Jan Hutař
Modified: 2009-09-10 15:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn_search.log (last 1000 rows) (62.83 KB, application/octet-stream)
2009-01-22 04:31 EST, Jan Hutař
no flags Details
rhn_search_daemon.log (638.63 KB, application/octet-stream)
2009-01-22 04:33 EST, Jan Hutař
no flags Details
actual results (67.65 KB, image/png)
2009-02-22 21:46 EST, Jesus M. Rodriguez
no flags Details

  None (edit)
Description Jan Hutař 2009-01-22 04:31:23 EST
Description of problem:
While searching for "libvirt" in the fjs-0-14.rhndev.redhat.com we are currently using for KS testing, I have noticed it founds packages which it should not find and libvirt is listed 3 times


Version-Release number of selected component (if applicable):
Red Hat Network release 5.2.0
rhn-search-5.2.0-4.el4


How reproducible:
always


Steps to Reproduce:
1. search for package "libvirt"


Actual results:
 * "libvirt" is found 3 times
 * when I select "What to search: Name only", search returns packages which
   do not have "libvirt" in their names as well
 * when I select "What to search: Name only", search highlights "libvirt"
   in summary as well


Expected results:
Should work as expected
Comment 1 Jan Hutař 2009-01-22 04:31:59 EST
Created attachment 329700 [details]
rhn_search.log (last 1000 rows)
Comment 2 Jan Hutař 2009-01-22 04:33:25 EST
Created attachment 329701 [details]
rhn_search_daemon.log
Comment 3 Jesus M. Rodriguez 2009-02-22 21:46:26 EST
Created attachment 332895 [details]
actual results

The behavior seen in the attached graphic is actually the correct behavior intended for this feature. We do *NOT* do exact matches anymore like we did with database searches. When searching libvirt it actually searches for libvirt and virt, and probably other combinations. We sort by the score which is why you have libvirt at the top. We also remove the very low scoring results from the list.

The reason you see 3 libvirts are because the summaries are different so we show all there that were found.
Comment 4 Jesus M. Rodriguez 2009-02-22 21:58:13 EST
The only thing I see addressing in this bug is that when
NAME_ONLY is passed in we highlight only the package name values,
anything else highlight BOTH columns: name and summary.

Highlighting is not perfect and only meant to help the user, but more
complex searches will result in nothing being highlighted, that is
to be expected.
Comment 5 Jesus M. Rodriguez 2009-02-22 22:09:30 EST
changed title from 'incorrect search results' to 'incorrect search highlighting'
Comment 6 Jesus M. Rodriguez 2009-02-22 22:22:56 EST
fixed in 8cd273cd4a458c6eaa6544e102bd741ee2640f03
Comment 7 Preethi Thomas 2009-03-16 11:11:25 EDT
verified
Satellite-5.3.0-RHEL5-re20090306.2-i386-embedded-oracle.iso

* Package search for libvirt with name only
* only libvirt in the the name only field is highlighted
Comment 8 Jan Pazdziora 2009-09-01 08:23:54 EDT
Stage validated. Only (parts of) package names are highlighted when doing "Nor Name" Suche.

However, I find this behaviour strongly contraintuitive -- if I search Name Only for libvirt, I do not want to see perl-Sys-Virt. Moving to RELEASE_PENDING but also adding to triage for further fix.
Comment 9 Jan Pazdziora 2009-09-02 03:45:37 EDT
Removing the sat600-triage. I have filed new bug 520752 for the "searches are too fuzzy" problem.
Comment 10 Brandon Perkins 2009-09-10 15:31:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.