Bug 481130 - %preun failure in spacewalk-java when uninstalling together with spacewalk-taskomatic
%preun failure in spacewalk-java when uninstalling together with spacewalk-ta...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Jan Hutař
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-01-22 05:11 EST by Jan Hutař
Modified: 2009-09-10 14:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-01-22 05:11:21 EST
Description of problem:
I'm getting %preun failure in spacewalk-java package when I try to uninstall it from previously not completed installation.


Version-Release number of selected component (if applicable):
spacewalk-java-0.4.10-2.el5
spacewalk-java-lib-0.4.10-2.el5.noarch
spacewalk-taskomatic-0.4.10-2.el5.noarch


How reproducible:
always (?)


Steps to Reproduce:
1. # rpm -e spacewalk-java spacewalk-java-lib spacewalk-taskomatic


Actual results:
error reading information on service taskomatic: No such file or directory
error: %preun(spacewalk-java-0.4.10-2.el5.noarch) scriptlet failed, exit status 1
# rpm -q spacewalk-java spacewalk-java-lib spacewalk-taskomatic
spacewalk-java-0.4.10-2.el5   # <<< still installed!
package spacewalk-java-lib is not installed
package spacewalk-taskomatic is not installed


Expected results:
no errors
# rpm -q spacewalk-java spacewalk-java-lib spacewalk-taskomatic
package spacewalk-java is not installed
package spacewalk-java-lib is not installed
package spacewalk-taskomatic is not installed


Additional info:
# rpm -q --scripts spacewalk-java
preuninstall scriptlet (using /bin/sh):
if [ $1 = 0 ] ; then
   /sbin/service taskomatic stop >/dev/null 2>&1
   /sbin/chkconfig --del taskomatic
fi

Maybe just adding `exit 0` to the end could do it - anyway, shouldn't `chkconfig --del taskomatic` be performed by spacewalk-taskomatic package?
Comment 1 Devan Goodwin 2009-04-02 15:39:32 EDT
Fixed in c42a3a8.

Moved the scriptlet to be specific to the taskomatic subpackage, the post above it looks like it really should not be on the java package.
Comment 2 Jan Hutař 2009-05-29 02:58:26 EDT
VERIFIED as I have not seen this on the 20090521.1 (RHEL5, x86_64).
Comment 3 Brandon Perkins 2009-08-07 16:24:47 EDT
Release Pending.  Looks clean removing all three, all three disappear, and able to install fresh copies.
Comment 4 Brandon Perkins 2009-09-10 14:53:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.