Bug 481261 - initscript condrestart does not call status
initscript condrestart does not call status
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 02:17 EST by Ingvar Hagelund
Modified: 2009-04-20 08:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 08:01:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2009-01-23 02:17:29 EST
Description of problem:
initscript condrestart does not call status

Version-Release number of selected component (if applicable):
4.2.4p5-2.fc10 (and all previous)

How reproducible:
Always

Steps to Reproduce:
1. service ntpd start
2. pkill -9 ntpd
3. service ntpd condrestart

Actual results:
daemon starts though it was dead

Expected results:
daemon was dead, and should not be resurrected just because the pidfile exists

Additional info:
This behaviour is typically old-style RedHat, and many daemon init scripts
behave like this. According to 
http://fedoraproject.org/wiki/Packaging/SysVInitScript
condrestart and try-restart should use the status function (from
/etc/sysconfig/functions), and not just rely on the pidfile.
Comment 1 Miroslav Lichvar 2009-04-20 08:01:50 EDT
Fixed in ntp-4.2.4p6-4.fc11. Thanks.

Note You need to log in before you can comment on or make changes to this bug.