Bug 481280 - Firefox hangs on certain website
Firefox hangs on certain website
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 07:27 EST by markm
Modified: 2009-02-06 05:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 05:43:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firefox run within GDB (5.59 KB, text/plain)
2009-01-23 08:29 EST, Dawid Lorenz
no flags Details
Firefox GDB backtrace log (7.91 KB, text/plain)
2009-01-23 08:30 EST, Dawid Lorenz
no flags Details

  None (edit)
Description markm 2009-01-23 07:27:05 EST
Description of problem:

when I want to use http://examples.kevinandre.com/growler1.0.0/index.html
firefox hangs and system becomes unresponsive.

Version-Release number of selected component (if applicable):

firefox-3.0.5-1.fc10.i386

How reproducible:

tested on two different machines with default firefox, tested with clean profile - same effect.

Steps to Reproduce:
1. Fire firefox
2. open website http://examples.kevinandre.com/growler1.0.0/index.html
3. try to do anything
  
Actual results:

browser hangs, eats 100% of cpu, Gnome hangs as well, if you're lucky enough to close the tab, everything backs to normal

Expected results:

firefoks should work fine

Additional info:

Problem applies only to firefox shipped with fedora, Minefield or Firefox downloaded from mozilla.org are not affected and work fine. Also Firefox 3.0.5 on Ubuntu seems to work fine. There is something wrong with default firefox in fedora.
Comment 1 Matěj Cepl 2009-01-23 08:00:14 EST
Just works for me. Could you please provide any more information how to reproduce this on our computers, please? 

First of all, could we get output of the command

	rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox freeze. When it happens, you should go back to the gdb, and try to stop firefox with Ctrl-C; then run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

Could you also try to reproduce this in the safe mode, please (i.e., all plugins off) -- run firefox as firefox -safe-mode?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Dawid Lorenz 2009-01-23 08:12:53 EST
I'm having the same problem, and below is my rpm -qa output. I'll play with gdb little bit later.

[root@m4300 ~]# rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*
totem-mozplugin-2.24.3-1.fc10.i386
flash-plugin-10.0.12.36-release.i386
anaconda-yum-plugins-1.0-3.fc10.noarch
mail-notification-evolution-plugin-5.4-4.fc10.i386
setroubleshoot-plugins-2.0.12-1.fc10.noarch
xulrunner-devel-1.9.0.5-1.fc10.i386
gstreamer-plugins-ugly-0.10.10-2.fc10.i386
plymouth-plugin-label-0.6.0-0.2008.11.17.3.fc10.i386
gstreamer-plugins-base-0.10.21-2.fc10.i386
xulrunner-1.9.0.5-1.fc10.i386
gstreamer-plugins-good-0.10.11-1.fc10.i386
plymouth-system-plugin-0.6.0-0.2008.11.17.3.fc10.i386
PackageKit-yum-plugin-0.3.12-1.fc10.i386
PackageKit-gstreamer-plugin-0.3.12-1.fc10.i386
firefox-3.0.5-1.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
nspluginwrapper-1.1.10-1.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
plymouth-plugin-solar-0.6.0-0.2008.11.17.3.fc10.i386
gstreamer-plugins-schroedinger-1.0.5-3.fc10.i386
gstreamer-plugins-bad-0.10.9-1.fc10.i386
mozilla-filesystem-1.9-2.fc10.i386
gstreamer-plugins-bad-extras-0.10.9-1.fc10.i386
Comment 3 Dawid Lorenz 2009-01-23 08:29:36 EST
Created attachment 329830 [details]
Firefox run within GDB
Comment 4 Dawid Lorenz 2009-01-23 08:30:01 EST
Created attachment 329831 [details]
Firefox GDB backtrace log
Comment 5 Dawid Lorenz 2009-01-23 08:32:45 EST
Added relevant GDB outputs. Also, running Firefox in -safe-mode doesn't help.

Btw, Matej - did you try to actually click through the sie at URL mentioned? Loading it itself is not *that* painful, as trying to click through the buttons/tabs at the top or even scroll page down.
Comment 6 Matěj Cepl 2009-01-24 19:44:27 EST
(In reply to comment #5)
> Btw, Matej - did you try to actually click through the sie at URL mentioned?
> Loading it itself is not *that* painful, as trying to click through the
> buttons/tabs at the top or even scroll page down.

Of course I did -- worked pretty well with immediate reactions.
Comment 7 Dawid Lorenz 2009-01-24 19:53:26 EST
I am now on my home machine, with Fedora 10 with latest updates and Firefox, and it looks like this website is working quite well here! :-o Here is some output you've requested earlier:

[root@d620 ~]# rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*
gstreamer-plugins-base-0.10.21-2.fc10.i386
gstreamer-plugins-schroedinger-1.0.5-3.fc10.i386
flash-plugin-10.0.12.36-release.i386
anaconda-yum-plugins-1.0-3.fc10.noarch
plymouth-system-plugin-0.6.0-0.2008.11.17.3.fc10.i386
firefox-3.0.5-1.fc10.i386
xulrunner-devel-1.9.0.5-1.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
plymouth-plugin-solar-0.6.0-0.2008.11.17.3.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
gstreamer-plugins-ugly-0.10.10-2.fc10.i386
mozilla-filesystem-1.9-2.fc10.i386
totem-mozplugin-2.24.3-1.fc10.i386
gstreamer-plugins-bad-extras-0.10.9-1.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.i386
setroubleshoot-plugins-2.0.12-1.fc10.noarch
xulrunner-1.9.0.5-1.fc10.i386
gstreamer-plugins-farsight-0.12.9-3.fc10.i386
plymouth-plugin-label-0.6.0-0.2008.11.17.3.fc10.i386
gstreamer-plugins-good-0.10.11-1.fc10.i386
gstreamer-plugins-bad-0.10.9-1.fc10.i386
PackageKit-yum-plugin-0.3.12-1.fc10.i386
PackageKit-gstreamer-plugin-0.3.12-1.fc10.i386
nspluginwrapper-1.1.10-1.fc10.i386

Can you spot any major differences?
Comment 8 François Cami 2009-02-05 19:30:26 EST
Marek, Dawid,
Are you connecting through a proxy when it fails ?
If yes, I suppose other browsers work just fine with the site ?
If no, could you try running as root :
echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
And try again.
Thanks
Comment 9 Dawid Lorenz 2009-02-06 05:16:37 EST
(In reply to comment #8)
> Marek, Dawid,
> Are you connecting through a proxy when it fails ?

No, at least not intentionally. I don't know whether there is some kind of transparent proxy on our office network (both me and Marek work in the same place).

> If yes, I suppose other browsers work just fine with the site ?
> If no, could you try running as root :
> echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
> And try again.

Wow, to be honest, now this website works now fine, whether I run that command or not! Perhaps the last system update have changed something?
Comment 10 Matěj Cepl 2009-02-06 05:43:07 EST
Cool, thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.