Bug 481282 - yum-fastestmirror is too noisy per default
yum-fastestmirror is too noisy per default
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 07:32 EST by Matěj Cepl
Modified: 2014-01-21 18:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 10:04:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of possible solution (2.09 KB, patch)
2009-01-23 07:32 EST, Matěj Cepl
no flags Details | Diff
probably better version of the patch (780 bytes, patch)
2009-01-23 07:35 EST, Matěj Cepl
no flags Details | Diff

  None (edit)
Description Matěj Cepl 2009-01-23 07:32:29 EST
Created attachment 329814 [details]
example of possible solution

Description of problem:
I don't think I like having the list of all "best" servers whenever I run yum. Could we bump loglevel of yum-fastestmirror plugin to 3 (e.g., see the attached patch)?

Version-Release number of selected component (if applicable):
yum-fastestmirror-1.1.19-1.fc10.noarch
Comment 1 Matěj Cepl 2009-01-23 07:35:33 EST
Created attachment 329815 [details]
probably better version of the patch

I probably went over the top -- this is slightly more sane.
Comment 2 Matěj Cepl 2009-01-23 07:40:16 EST
And yes, the package still builds http://koji.fedoraproject.org/koji/taskinfo?taskID=1076135
Comment 3 Tim Lauridsen 2009-01-26 09:20:29 EST
Looks sane to me, I have added it upstream
Comment 4 Tim Lauridsen 2009-01-26 09:28:57 EST
I was a little fast here :)

Luke, what do you think about this one.
Comment 5 Luke Macken 2009-01-26 09:47:51 EST
I personally like seeing what mirrors I'm hitting, and don't really consider 1 line of output per mirrorlist as being "noisy".  I added this functionality a while back because I Max Spevack asked for it.

I vote for having it output the fastest mirrors by default, and making it simple to turn it off.  However, if people really really want it off by default, that's OK with me too.  Not sure we can make everyone happy with this one.
Comment 6 James Antill 2009-01-26 10:04:40 EST
 I added a "always_print_best_host" bool config. option, when true it prints at level 2 when false it prints at level 3. Default is the historical behaviour.
Comment 7 Matěj Cepl 2009-01-26 11:03:25 EST
(In reply to comment #5)
> I personally like seeing what mirrors I'm hitting, and don't really consider 1
> line of output per mirrorlist as being "noisy".  I added this functionality a
> while back because I Max Spevack asked for it.

Well, it looks very much like a debugging functinoality, which shouldn't be on per default, but james's solution works for me as well.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.