Bug 481301 - new gnome-terminals should be the same size as their parent
new gnome-terminals should be the same size as their parent
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
14
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 09:22 EST by Joel Uckelman
Modified: 2010-11-23 18:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 18:22:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2009-01-23 09:22:24 EST
Description of problem:

CTRL-SHIFT-N spawns a new gnome-terminal from an existing one. The new gnome-terminal will always be the 80x24, regardless of the size of the parent gnome-terminal. This is obnoxious. No other program works this way. If the user has sized the parent gnome-terminal to something other than 80x24 then it is much more likely that he will want new terminals to be that size also. Consider how irritating it would be if you spawned a new window in Firefox and it was always created at some predetermined size instead of at the size at which you tend to keep your browser window. This is exactly the situation with gnome-terminal.

For example, I run my terminals at 80x50. Every time I spawn a new gnome-terminal with CTRL-SHIFT-N, the first thing I do is resize it to 80x50. It gets old having had to do this every time I spawn a new terminal for the past six or seven years. (It's even worse because of Bug 473896, which prevents me from using compiz and resizing windows which have their dimensions in characters).  If I wanted my terminals to be 80x24, I would never have launched my original gnome-terminal with --geometry 80x50.

I've seen this problem reported elsewhere several times:

Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505327
GNOME:  http://bugzilla.gnome.org/show_bug.cgi?id=155147

When Debian sent it upstream to GNOME in 2008, the GNOME bug already had a patch which would fix this problem which dated back to 2006:

http://bugzilla.gnome.org/attachment.cgi?id=62603

The fact that there's been a patch (which is completely trivial and changes a grand total of 11 lines of actual code) to fix this problem in existence for nearly three years now makes me despair of ever seeing any movement from GNOME on the issue. I think that Fedora should take the lead and add this patch to the gnome-terminal it distributes.

Version-Release number of selected component (if applicable):

gnome-terminal-2.24.2-3.fc10.x86_64


How reproducible:

Always.

Steps to Reproduce:
1. Run gnome-terminal.
2. Resize it to something other than 80x24.
3. Hit CTRL-SHIFT-N.
  
Actual results:

A new terminal appears, sized 80x24.


Expected results:

A new terminal appears, sized as the parent terminal was.
Comment 1 Joel Uckelman 2010-11-23 18:22:48 EST
This is fixed in gnome-terminal-2.32.0-1.fc14.x86_64, as it now has a "Use custom default terminal size" option.

Note You need to log in before you can comment on or make changes to this bug.