Bug 481412 - yum fails to install 32bit libX11
yum fails to install 32bit libX11
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 02:24 EST by Elmar
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-24 14:33:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elmar 2009-01-24 02:24:56 EST
Hi all,

I need to run a 32bit application. In Fedora 9 64bit, this worked well, all I had to do was..

yum install libX11.i386
yum install libXext.i386

But this is broken now in Fedora 10 64bit:

yum install libX11.i386

Loaded plugins: refresh-packagekit
fedora                                                   | 2.8 kB     00:00
fedora/primary_db                                        | 8.1 MB     01:03
updates                                                  | 2.3 kB     00:00
updates/primary_db                                       | 2.3 MB     00:18
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package libX11.i386 0:1.1.4-6.fc10 set to be updated
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: libX11
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.3.2) for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: libX11
--> Processing Dependency: libxcb-xlib.so.0 for package: libX11
--> Processing Dependency: libc.so.6 for package: libX11
--> Processing Dependency: libdl.so.2 for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: libX11
--> Processing Dependency: libc.so.6(GLIBC_2.1.2) for package: libX11
--> Processing Dependency: libxcb.so.1 for package: libX11
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: libX11
--> Running transaction check
--> Processing Dependency: glibc = 2.9-2 for package: glibc-headers
--> Processing Dependency: glibc = 2.9-2 for package: glibc-devel
--> Processing Dependency: glibc = 2.9-2 for package: glibc-common
---> Package libxcb.i386 0:1.1.91-5.fc10 set to be updated
--> Processing Dependency: libXdmcp.so.6 for package: libxcb
--> Processing Dependency: libXau.so.6 for package: libxcb
---> Package glibc.x86_64 0:2.9-3 set to be updated
---> Package glibc.i686 0:2.9-3 set to be updated
--> Running transaction check
---> Package libXdmcp.i386 0:1.0.2-6.fc10 set to be updated
---> Package libXau.i386 0:1.0.4-1.fc10 set to be updated
---> Package glibc-devel.x86_64 0:2.9-3 set to be updated
---> Package glibc-common.x86_64 0:2.9-3 set to be updated
---> Package glibc-headers.x86_64 0:2.9-3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch          Version                Repository      Size
================================================================================
Installing:
 libX11               i386          1.1.4-6.fc10           updates        825 k
Updating:
 glibc                x86_64        2.9-3                  updates        5.1 M
 glibc-common         x86_64        2.9-3                  updates         22 M
 glibc-devel          x86_64        2.9-3                  updates        2.5 M
 glibc-headers        x86_64        2.9-3                  updates        606 k
Installing for dependencies:
 glibc                i686          2.9-3                  updates        5.7 M
 libXau               i386          1.0.4-1.fc10           fedora          20 k
 libXdmcp             i386          1.0.2-6.fc10           fedora          21 k
 libxcb               i386          1.1.91-5.fc10          fedora         124 k

Transaction Summary
================================================================================
Install      5 Package(s)
Update       4 Package(s)
Remove       0 Package(s)

Total download size: 37 M
Is this ok [y/N]: y
Downloading Packages:
(1/9): libXau-1.0.4-1.fc10.i386.rpm                      |  20 kB     00:00
(2/9): libXdmcp-1.0.2-6.fc10.i386.rpm                    |  21 kB     00:00
(3/9): libxcb-1.1.91-5.fc10.i386.rpm                     | 124 kB     00:01
(4/9): glibc-headers-2.9-3.x86_64.rpm                    | 606 kB     00:04
(5/9): libX11-1.1.4-6.fc10.i386.rpm                      | 825 kB     00:06
(6/9): glibc-devel-2.9-3.x86_64.rpm                      | 2.5 MB     00:18
(7/9): glibc-2.9-3.x86_64.rpm                            | 5.1 MB     00:41
(8/9): glibc-2.9-3.i686.rpm                              | 5.7 MB     00:44
(9/9): glibc-common-2.9-3.x86_64.rpm                     |  22 MB     02:45
--------------------------------------------------------------------------------
Total                                           131 kB/s |  37 MB     04:44
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 4ebfc273
fedora/gpgkey                                            | 2.3 kB     00:00
Importing GPG key 0x4EBFC273 "Fedora (10) <fedora@fedoraproject.org>" from /etc/
pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/X11/XKeysymDB from install of libX11-1.1.4-6.fc10.i386 conflic
ts with file from package libX11-1.1.4-5.fc10.x86_64



I googled around, and some people claim that Fedora 10 completely dropped 32bit compatibility. But I can't believe that, because Fedora is the base for Red Hat Enterprise Linux, and Red Hat could never afford to lock out 32bit apps, since they depend on subscription payments...? ;-)

Many thanks for your help,
Elmar
Comment 1 James Antill 2009-01-24 14:33:45 EST
 This isn't a bug in yum, as yum can't do anything about it. Newer rpms have been fixed to not be quite as weird in this case, in that older rpm versions won't complain as long as both the .i386 and .x86_64 packages are installed at once.
 Working around your problem now probably involves using rpm --force.
Comment 2 Panu Matilainen 2009-01-26 02:54:31 EST
Hmm, actually the issue here is that libX11 i386 and x86_64 are of different versions, apparently causing /usr/share/X11/XKeysymDB contents to differ:
libX11-1.1.4-5.fc10.x86_64 vs libX11-1.1.4-6.fc10.i386

Doing 'yum update' before installing libX11.i386 should sort out the issue.
Comment 3 Elmar 2009-01-26 05:32:06 EST
Yes, thanks this was the problem.

So if you want to install a 32bit library, and your internet connection is too slow to do a full 700 MB 'yum update' before, just specify both at the same time:

yum install libX11.i386 libX11.x86_64
yum install libXext.i386 libXext.x86_64

Works fine now!

Elmar

Note You need to log in before you can comment on or make changes to this bug.