This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 481417 - RFE: enable RTREE extension (and possibly FTS3)
RFE: enable RTREE extension (and possibly FTS3)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 05:58 EST by Thomas Sailer
Modified: 2009-02-04 11:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 11:40:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Sailer 2009-01-24 05:58:08 EST
sqlite is currently compiled with RTREE (and FTS3) disabled. RTREE is a virtual table to speed up querying geographical data. FTS3 is also a virtual table to speed up full text searching.

I have an application which I'm trying to get into Fedora that would greatly benefit from RTREE (although it's a bit stalled on the prerequisites review).

Since these are virtual tables, enabling these shouldn't cause any problems to applications that don't use these extensions.

To enable RTREE and FTS3, add -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 to CFLAGS.

Thanks.
Comment 1 Panu Matilainen 2009-02-04 11:40:18 EST
Sure, why not. RTREE and FTS3 should be enabled in sqlite-3.6.10-3.fc11 now in rawhide.

Note You need to log in before you can comment on or make changes to this bug.