Bug 481430 - kbuildsycoca4 crashing when starting amarok
kbuildsycoca4 crashing when starting amarok
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 13:22 EST by Deb Mukherjee
Modified: 2009-03-18 08:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 08:42:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (372.18 KB, image/png)
2009-01-24 13:27 EST, Deb Mukherjee
no flags Details

  None (edit)
Description Deb Mukherjee 2009-01-24 13:22:52 EST
Description of problem:
$amarok
virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) "default" 
Object::connect: No such slot MainWindow::showStatistics()
Object::connect:  (receiver name: 'MainWindow')
kbuildsycoca4 running...
kbuildsycoca4(9908) KBuildMimeTypeFactory::createEntry: Missing <comment> field in  "/usr/share/mime/audio/x-sbc.xml" 
[badsha 13:20:09 ~] $ kbuildsycoca4(9908) KBuildMimeTypeFactory::createEntry: Missing <comment> field in  "/usr/share/mime/application/x-hcidump.xml" 
kbuildsycoca4(9908)/kdecore (KService) KServicePrivate::init: The desktop entry file "ServiceMenus/smplayer_enqueue.desktop" has an empty mimetype! 
kbuildsycoca4(9908) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/gpk-install-catalog.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(9908) KConfigGroup::readXdgListEntry: List entry MimeType in "/usr/share/applications/redhat-audio-player.desktop" is not compliant with XDG standard (missing trailing semicolon). 
KCrash: Application 'kbuildsycoca4' crashing...
sock_file=/home/badsha/.kde/socket-badsha/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.


Version-Release number of selected component (if applicable):
Qt: 4.4.3
KDE: 4.1.80 (KDE 4.1.80 (KDE 4.2 Beta1))
Amarok: 2.0.1


How reproducible:
always

Steps to Reproduce:
1.start amarok
2.
3.
  
Actual results:
kbuildsycoca4 crashing

Expected results:
amarok should start

Additional info:
Comment 1 Deb Mukherjee 2009-01-24 13:27:04 EST
Created attachment 329913 [details]
screenshot
Comment 2 Rex Dieter 2009-01-24 13:51:00 EST
Try up'ing to at least kde-4.2-rc1 (4.1.96) to see if the problem persists.
Comment 3 Steven M. Parrish 2009-03-16 20:59:08 EDT
Is this still an issue with the recent releases?
Comment 4 Deb Mukherjee 2009-03-18 00:07:12 EDT
The problem was fixed with kde-4.2-rc1 as Rex suggested and can not be reproduced with the recent updates. So I think this thread can be closed.
thanks for all the help.
Deb

Note You need to log in before you can comment on or make changes to this bug.