Bug 481449 - enchant tries to load 32-bit libraries and prints an error message
enchant tries to load 32-bit libraries and prints an error message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: enchant (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 19:00 EST by Philippe Troin
Modified: 2009-06-29 16:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 16:04:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2009-01-24 19:00:15 EST
Description of problem:

$ rpm -qa | grep enchant
enchant-1.4.2-4.fc10.i386
enchant-1.4.2-4.fc10.x86_64
enchant-aspell-1.4.2-4.fc10.x86_64
enchant-devel-1.4.2-4.fc10.i386
enchant-devel-1.4.2-4.fc10.x86_64
enchant-voikko-1.4.2-4.fc10.x86_64
python-enchant-1.3.1-2.fc9.x86_64

-- note that I have both i386 and x86_64 for enchange and enchant-devel

$ enchant -l < /dev/null

** (process:10912): WARNING **: Error loading plugin: /usr/lib/enchant/libenchant_myspell.so: wrong ELF class: ELFCLASS32

$
Comment 1 Caolan McNamara 2009-06-29 16:04:43 EDT
I logged a fix for this upstream as http://bugzilla.abisource.com/show_bug.cgi?id=12160 and it is now in rawhide (F-12). The warning is merely cosmetic in practice, so I don't think its worth fixing in a F-10 update, but thanks for the report

Note You need to log in before you can comment on or make changes to this bug.