Bug 481505 - No BrowseLocalProtocols by default
No BrowseLocalProtocols by default
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-25 14:20 EST by Christopher Beland
Modified: 2009-07-13 07:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.0.15-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 07:54:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 3037 None None None Never

  None (edit)
Description Christopher Beland 2009-01-25 14:20:10 EST
I ran the troubleshooter from the Help menu in system-config-printer while testing another bug. Not far into the process, I got a screen titled "Server Not Exporting Printers" which was frustrating for several reasons:

* I cannot use system-config-printer while the troubleshooter is running; clicking on menu items has no effect.
* It's not possible to copy-and-paste the text so as to follow the instructions after the troubleshooter is closed, or to use in bug reports.  (I've attached a screenshot instead.)
* It says to activate the "Publish shared printers connected to this system" setting, but I have already done so.  This page should not have appeared in the first place.

This is with system-config-printer-1.1.2-1.fc11.x86_64.
Comment 1 Tim Waugh 2009-01-27 08:18:04 EST
I've changed the troubleshooter window so that it is no longer modal for the main window, so that both can be used at the same time.  Now we don't need to select the text.

The reason for the false alarm is actually a CUPS bug.
Comment 2 Fedora Update System 2009-02-24 15:47:04 EST
system-config-printer-1.0.15-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2009-02-24 15:58:53 EST
system-config-printer-1.0.15-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Christopher Beland 2009-02-24 16:37:22 EST
Thanks for making the interface more flexible; that's definitely nicer.

For the record, I'm still getting the "Server Not Exporting Printers" window inappropriately with system-config-printer-1.1.4-2.fc11.x86_64 and
cups-1.4-0.b2.7.fc11.x86_64.
Comment 5 Tim Waugh 2009-02-25 06:45:42 EST
What does 'grep Browse /etc/cups/cupsd.conf' say, as root?  I suspect you have a version that contained a bug, and that it wasn't replaced due to other alterations to the configuration.
Comment 6 Christopher Beland 2009-02-25 11:02:13 EST
"grep Browse /etc/cups/cupsd.conf" reports:

BrowseOrder allow,deny
BrowseAllow all
BrowseRemoteProtocols CUPS
BrowseAddress @LOCAL
BrowseLocalProtocols @CUPS_DEFAULT_BROWSE_LOCAL_PROTOCOLS@
Comment 7 Tim Waugh 2009-02-25 11:57:59 EST
Change this line:

BrowseLocalProtocols @CUPS_DEFAULT_BROWSE_LOCAL_PROTOCOLS@

to:

BrowseLocalProtocols CUPS dnssd

(or just perform a clean reinstall of the cups package).
Comment 8 Christopher Beland 2009-02-26 18:28:19 EST
I did have a cups.conf.rpmnew that I missed.  However, even after doing a clean install, there are still problems:

Immediately after a clean install, this it what I get from the grep:

BrowseOrder allow,deny
BrowseAllow all
BrowseLocalProtocols CUPS dnssd

I start up my printer and it gets auto-configured (though I can't print to it, separate bug) and marked as shared.

If I run the troubleshooter, I don't get the "Server Not Exporting Printers" page, but after getting to the end of the troubleshooting process, I get from the grep:

BrowseOrder allow,deny
BrowseAllow all
BrowseRemoteProtocols CUPS
BrowseLocalProtocols

I did need to supply the root password to enable debugging, so perhaps that step changes the file.

However, I *should have* gotten the "Server Not Exporting Printers" page, because then when I go to "Server -> Settings", I see that "Publish shared printers connected to this system" is unchecked.  After enabling this and "Allow printing from the Internet", the grep produces:

BrowseOrder allow,deny
BrowseAllow all
BrowseRemoteProtocols CUPS
BrowseAddress @LOCAL
BrowseLocalProtocols 

Now the troubleshooter *does* show the "Server Not Exporting Printers" page, wrongly.
Comment 9 Bug Zapper 2009-06-09 06:53:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Tim Waugh 2009-07-13 07:54:12 EDT
I don't see this with Fedora 11 final.  The cupsd.conf.default file (which is a copy of the as-shipped cupsd.conf) has this:

BrowseOrder allow,deny
BrowseAllow all
BrowseLocalProtocols CUPS

Note You need to log in before you can comment on or make changes to this bug.