Bug 481579 - fsc is no longer available for nfs mount points after upgrading from nfs-utils-1.0.9-35z.el5_2 to nfs-utils-1.0.9-40.el5.
fsc is no longer available for nfs mount points after upgrading from nfs-util...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.3
All Linux
low Severity high
: rc
: ---
Assigned To: Steve Dickson
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 10:18 EST by Mark London
Modified: 2009-03-20 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 13:43:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark London 2009-01-26 10:18:14 EST
Description of problem:

The nfs option fsc is no longer available for nfsv3 mount points after upgrading from nfs-utils-1.0.9-35z.el5_2 to nfs-utils-1.0.9-40.el5.  This only becomes apparent after a reboot of the system, when the mount points no longer will mount.  I can't find any documentation on the web for this new path (nfs-utils-1.0.9-40.el5).  Thanks. - Mark 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark London 2009-01-26 13:35:53 EST
Correction, the fsc option is no longer available for nfs for any version,  not just v3.  We just tried it for v4 and the mount command also does not recognize it:

[root@cmodws09 ~]# mkdir /foo
[root@cmodws09 ~]# mount -o fsc -t nfs4 test:/ /foo
unknown nfs mount option: fsc
[root@cmodws09 ~]# mount -o fsc test:/ /foo
Unsupported nfs mount option: fsc
Comment 2 Mark London 2009-02-13 09:47:34 EST
Can I get someone to respond to this reported problem?  Thanks! - Mark
Comment 3 Steve Dickson 2009-02-13 13:43:10 EST
Sorry for the delay.... 

FS-Cache was technology preview, which meant we were not going
to guarantee any support and had the right to disable it at anytime.

Since the technology never was accepted into the Linux mainline
kernel (what we refer to as upstream), it was decided to disable
the technology in the RHEL 5.3 release. That's the bad news...

The good news is there is a very good chance FS-Cache technology
will be accepted in mainline kernel very soon. Which means there
is a good chance the technology will reappear in RHEL 6

The latest code release can be found on the 'linux-mm' branch
upstream NFS maintainter's git tree which can be found at:
    git://git.linux-nfs.org/pub/linux/nfs-2.6.git
Comment 4 Mark London 2009-02-13 15:57:20 EST
Thanks for the info! - Mark
Comment 5 Matthias Saou 2009-03-20 12:26:33 EDT
Just for the sake of completeness : It's not the userspace tools which no longer permit using the option, it's apparently the RHEL 5.3 kernel (2.6.18-128.el5+) which no longer supports the feature. Too bad, really.

Note You need to log in before you can comment on or make changes to this bug.