Bug 481619 - Adding ac97-module (from qemu-repo)
Adding ac97-module (from qemu-repo)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 13:48 EST by Stefan Neufeind
Modified: 2009-03-20 13:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 13:37:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2009-01-26 13:48:49 EST
Windows Vista works fine in a qemu-kvm-enviroment. However the supported two (virtual) soundcards are "that old" that no drivers for Vista seem to exist. VirtualBox, to what I heard, works by using an emulated ac97-soundcard. Since VirtualBox is based on qemu there is also ac97-driver in the qemu-repo (as provided by VirtualBox). Maybe it would be possible to (try) to include that in a next build, so another soundcard exists as an option and maybe makes e.g. Windows Vista work even with sound out of the box?
Comment 1 Stefan Neufeind 2009-03-03 14:57:19 EST
FYI - kvm-84 adds ac97 by default:
http://www.mail-archive.com/kvm@vger.kernel.org/msg10585.html
Comment 2 Daniel Berrange 2009-03-11 09:11:45 EDT
The QEMU source tree in Fedora 10 is too old to support the ac97 soundcard. We could however turn it on in the KVM package without much trouble.

Fedora 11/rawhide already has ac97 enabled by default for QEMU & KVM.
Comment 3 Mark McLoughlin 2009-03-20 13:37:44 EDT
Okay, lets just close this as "fixed in F11" then

Note You need to log in before you can comment on or make changes to this bug.