Bug 48163 - Latest xinetd packages break FILE logging
Latest xinetd packages break FILE logging
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2001-07-09 16:31 EDT by Jordan Russell
Modified: 2007-04-18 12:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-27 16:36:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2001-07-09 16:31:06 EDT
Description of problem:
The problem is that FILE logging no longer works. There are no error 
messages anywhere and nothing at all is written to the file.

The version of xinetd that comes with Red Hat 7.1 ( works 
fine. But these versions of xinetd - found in the Red Hat Updates - do not:

How reproducible:

Steps to Reproduce:
Try this file with one of the newer xinetd packages. xinetd will create 
the file /var/log/cvs.log, but when you do "telnet localhost cvspserver", 
nothing is written to it.

service cvspserver
        socket_type             = stream
        protocol                = tcp
        wait                    = no
        user                    = root
        log_type                = FILE /var/log/cvs.log
        log_on_success          += USERID DURATION
        log_on_failure          += USERID
        server                  = /usr/bin/env
        server_args             = -u HOME /usr/bin/cvs -f --allow-
root=/data/cvs pserver
        instances               = 10
Comment 1 Trond Eivind Glomsrxd 2001-07-13 17:35:57 EDT
Works for me with telnet...  I'll set up a CVS repository to check to see if
it's specific to that service, although that sounds unlikely.
Comment 2 Jordan Russell 2001-07-13 17:58:37 EDT
You're right, I just tested with xinetd-2.3.0-1.71 and found that telnet does 
log correctly (with the same log_* lines). cvspserver does not, though..
Comment 3 Trond Eivind Glomsrxd 2001-07-13 18:01:51 EDT
And if you go back to the previous version  of xinetd (no other changes to
configuration), logging of cvspserver starts working again? That would be... weird.
Comment 4 Jordan Russell 2001-07-13 18:12:32 EDT
Exactly... It's like this:

# telnet localhost cvspserver
# cat /var/log/cvs.log

It worked. Now upgrade to the new package:

# rpm -UvhF xinetd-2.3.0-1.71.i386.rpm
# telnet localhost cvspserver
# cat /var/log/cvs.log

Nothing was written to the log that time. Now downgrade:

# rpm -Uvh --oldpackage xinetd-
# telnet localhost cvspserver
# cat /var/log/cvs.log

It works again.

I've repeated these steps many times with the same results.
Comment 5 Rob Braun 2001-08-31 16:53:03 EDT
Can this be reproduced with xinetd 2.3.3?  A bug in filelogging was fixed 
in that release.
Comment 6 Trond Eivind Glomsrxd 2001-08-31 19:16:31 EDT
2.3.3-1 is available from http://people.redhat.com/teg/xinetd/
Comment 7 Jordan Russell 2001-08-31 22:12:48 EDT
I upgraded to xinetd-2.3.3-1.i386.rpm and found that it's broken also.
Comment 8 Rob Braun 2001-08-31 22:49:43 EDT
This is really bizzare.  I'm able to reproduce with your specific case, but 
nothing else.  xinetd is calling the logging functions, but the xlog functions 
are somehow not writing it to the file.  It's not the file size checks...  Still 
Comment 9 Rob Braun 2001-09-01 14:26:33 EDT
Can you try xinetd at http://www.xinetd.org/~bbraun/xinetd-2001.9.1.tar.gz
I get filelogging with your exact config file and this version.
Comment 10 Jordan Russell 2001-09-01 15:00:43 EDT
Unfortunately, xinetd-2001.9.1 doesn't log anything either. In case it matters 
I compiled & installed it this way:

./configure --with-libwrap
mv xinetd/xinetd /usr/sbin
/etc/init.d/xinetd restart

xinetd[2878]: xinetd Version 2001.9.1 started with libwrap options compiled in.
Comment 11 Jordan Russell 2001-09-01 15:14:27 EDT
More info:
I've found that logging *does* work with xinetd-2001.9.1 when I run it like 

# /usr/sbin/xinetd -d

When it's ran as a background daemon without the -d switch:

# /usr/sbin/xinetd

it doesn't work!
Comment 12 Jordan Russell 2001-10-12 14:30:11 EDT
Well, I decided to go ahead and upgrade to the xinetd 2.3.3 to take advantage 
of the security fixes. While FILE logging is still non-functional, I found that 
SYSLOG logging does work, in case that's helpful to know. I'm now using this:

log_type = SYSLOG local5
Comment 13 Aleksey Nogin 2001-11-16 14:05:43 EST
I also see that in some cases, depending on how exactly I start xinetd it tries
to use syslog even when I have log_type = FILE /var/log/xxx in /etc/xinetd.conf

And in some of those cases strace shows that it does stat on /var/log *directory*...

Comment 14 Trond Eivind Glomsrxd 2001-12-05 16:56:18 EST
Can you try the xinetd package at http://people.redhat.com/teg/xinetd/, and see
if it helps? It's the development version from this week.
Comment 15 Jordan Russell 2001-12-07 18:28:08 EST
Nope, it's still broken with xinetd-2.3.4-0.2.i386.rpm.

FILE logging still only works when xinetd is started with -d (debug). Otherwise 
the log file is created but nothing is ever written to it; strace doesn't show 
any attempts to write log entries.
Comment 16 Trond Eivind Glomsrxd 2002-07-25 17:36:01 EDT
Any change with the current one (2.3.5) at the same location?
Comment 17 Jordan Russell 2002-07-27 16:36:11 EDT
Just tested it again, and found that xinetd-2.3.4-0.8.i386.rpm - the package 
that comes with Red Hat 7.3 - works! Wow, I was beginning to think the day 
would never come. :)

xinetd-2.3.5-5.i386.rpm also works.

So I guess this can finally be closed!

Note You need to log in before you can comment on or make changes to this bug.