Bug 481684 - adodb.inc.php file is missing at Fedora Moodle package
adodb.inc.php file is missing at Fedora Moodle package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: moodle (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 20:56 EST by Herli Menezes
Modified: 2009-03-26 10:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 10:05:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herli Menezes 2009-01-26 20:56:03 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc9 Firefox/3.0.5 Ubiquity/0.1.5

after installation and apache, php and mysql configuration, as http://localhost/moodle is called this error is reported:

[Wed Jan 21 17:15:11 2009] [error] [client 127.0.0.1] PHP Warning:  require_once(/var/www/moodle/web/lib/adodb/adodb.inc.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /var/www/moodle/web/lib/setup.php on line 124

[Wed Jan 21 17:15:11 2009] [error] [client 127.0.0.1] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/var/www/moodle/web/lib/adodb/adodb.inc.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/moodle/web/lib/setup.php on line 124

Reproducible: Always

Steps to Reproduce:
1.install and configure Moodle package
2. manually configure moodle config.php, setting database, username, password etc.
3. run http://localhost/moodle
Actual Results:  
[Wed Jan 21 17:15:11 2009] [error] [client 127.0.0.1] PHP Warning:  require_once(/var/www/moodle/web/lib/adodb/adodb.inc.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /var/www/moodle/web/lib/setup.php on line 124

[Wed Jan 21 17:15:11 2009] [error] [client 127.0.0.1] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/var/www/moodle/web/lib/adodb/adodb.inc.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/moodle/web/lib/setup.php on line 124

Expected Results:  
File adodb.inc.php must be at /var/www/moodle/web/lib/adodb/ folder
Comment 1 James Heather 2009-02-26 08:34:00 EST
I concur: I also have this problem, on the latest Moodle package for Fedora 10.

(I'm a bit surprised there's been no movement on this--the bug is now a month old.)

James
Comment 2 Anthony Green 2009-02-26 08:55:20 EST
This bug was filed against the wrong package.  Fixing now.
Comment 3 Gwyn Ciesla 2009-02-26 10:05:04 EST
There is an update coming to both 9 and 10 to fix other issues.  Can you confirm that this is broken once you get that update?

Sorry for the delay, this just came to my attention.
Comment 4 James Heather 2009-02-26 10:43:31 EST
I can't see any updates to moodle in F10 updates-testing.
Comment 5 Gwyn Ciesla 2009-02-26 11:03:16 EST
moodle-1.9.4-2.fc10 (and fc9) are in testing accoring to bodhi, and have been requested to be pushed to stable.

https://admin.fedoraproject.org/updates/F10/FEDORA-2009-1958

https://admin.fedoraproject.org/updates/F9/FEDORA-2009-1966
Comment 6 James Heather 2009-02-26 12:06:33 EST
Ta.

[root@derek ~]# rpm -Uvh /tmp/moodle-1.9.4-2.fc10.noarch.rpm 
Preparing...                ########################################### [100%]
	file /var/www/moodle/web/lib/magpie/rss_fetch.inc from install of moodle-1.9.4-2.fc10.noarch conflicts with file from package php-magpierss-0.72-4.fc10.noarch

It doesn't seem (according to koji) as though there is an update to php-magpierss available, and I can't remove it because it's a Moodle dep.

J.
Comment 7 Gwyn Ciesla 2009-02-26 12:13:47 EST
Oh, marvelous.  It's supposed to remove the symlink to php-magpierss and put back the bundled version.  If you:

rm /var/www/moodle/web/lib/magpie

and then update, it should work.  I've yanked the requests to push to stable, and will build a corrected version.

Thanks for catching this!
Comment 8 Gwyn Ciesla 2009-02-26 12:17:34 EST
Wait, except the spec for 1.9.4-2 has the following in %pre:

rm -rf /var/www/moodle/web/lib/smarty
rm -rf /var/www/moodle/web/lib/adodb
rm -rf /var/www/moodle/web/lib/magpie


So it should have worked.  Was that the only error you got?
Comment 9 James Heather 2009-02-26 12:27:17 EST
Yes, that was the only error.
Comment 10 James Heather 2009-02-26 12:29:32 EST
By the way, if you've put the bundled stuff in there, shouldn't php-magpierss no longer be a dependency?
Comment 11 James Heather 2009-02-26 12:36:23 EST
Sorry--dumb comment. It is no longer a dep.

I have now installed the update by using yum shell to remove php-magpierss and install the new rpm.

BUT... magpie is still a symlink to /usr/share/php/magpierss!
Comment 12 Gwyn Ciesla 2009-02-26 12:41:47 EST
Could have sworn I removed it, good catch.
Comment 13 James Heather 2009-02-26 12:43:34 EST
No idea what is going on. I have just uninstalled moodle, and then reinstalled
it. Now magpie is no longer a symlink, but smarty and adodb still are.

This, of course, means that the original bug report still holds. I still get
the error about missing adodb.inc.php. That presumably can't go away until
adodb stops being a symlink to somewhere that doesn't contain that file!
Comment 14 Gwyn Ciesla 2009-02-26 12:54:54 EST
Did it pull in php-adodb?  It's supposed to symlink to smarty and adodb.

adodb-php has the file at /usr/share/php/adodb/adodb.inc.php.
Comment 15 James Heather 2009-02-26 13:05:45 EST
Well, well. I've just discovered that my php-adodb installation had got corrupted. Half the files were missing, including adodb.inc.php.

I wonder how this happened? It could be that I did something stupid, but it is a bit odd that it happened on two of my machines, and that someone else was having the same problem.

Anyway--problem solved. Thanks for all your help. It works now.
Comment 16 Gwyn Ciesla 2009-02-26 13:17:10 EST
I thing I figured it out.  I was doing rm -rf on the symlink when I should have been doing rm -f.  That's why it followed the symlink and nuked php-adodb instead of merely removing the symlink.

Sorry about that.  I loathe having to deal with upstream bundled libs. :)
Comment 17 Gwyn Ciesla 2009-03-05 14:42:39 EST
How does the version in -testing look?
Comment 18 Gwyn Ciesla 2009-03-26 10:05:47 EDT
This is corrected, though there are other issues, see 489663.

Note You need to log in before you can comment on or make changes to this bug.