Bug 481780 - ypserv replaces /var/yp/Makefile
ypserv replaces /var/yp/Makefile
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ypserv (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: Patch
: 465275 700703 748584 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 10:34 EST by Peder Stray
Modified: 2012-02-21 00:53 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch for specfile (383 bytes, patch)
2011-04-29 03:05 EDT, Honza Horak
no flags Details | Diff
proposed patch for specfile (535 bytes, patch)
2011-04-29 03:20 EDT, Honza Horak
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 55407 None None None Never

  None (edit)
Description Peder Stray 2009-01-27 10:34:55 EST
Description of problem:

Latest update (2.19-5.el5) of ypbind replaces /var/yp/Makefile, a file that definitely should be regarded as a config file that should not be replaced by a normal package update.

/var/yp/Makefile typically includes some site-specific modifications, so here where we use ypserv it caused none of our maps to update correctly, because of an error, and when that error got fixed, it updated all maps with nothing, neither of which was very desirable.

Version-Release number of selected component (if applicable):

ypserv 2.19-5.el5

How reproducible:

upgrade from earlier package version, and the makefile gets replaced
Comment 1 Vitezslav Crhonek 2009-01-29 09:38:33 EST
Thanks for report. I agree with you, it's already fixed in Fedora Rawhide and should be fixed in RHEL too.
Comment 2 RHEL Product and Program Management 2009-03-26 12:46:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 Joe Pruett 2009-04-03 16:58:00 EDT
ouch, this one really bit us too.  i agree that it doesn't need to be fixed right away, but i do hope that the change will be in there before any more updates are made to ypserv to bite us again.
Comment 6 RHEL Product and Program Management 2010-08-09 14:22:03 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-11 15:29:59 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-01-12 10:25:24 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 11 Kalle Kiviaho 2011-04-20 09:11:15 EDT
Same happens with latest update ypserv-2.19-5.el5_6.1
Comment 12 Mark Huth 2011-04-21 22:45:23 EDT
This issue has affected a couple of customers recently.  

The customers in these cases had modified the MINUID value in the Makefile to less than the default value of 500.  When they upgraded the ypserv package, their Makefile was replaced and the MINUID was set back to 500.  Hence a number of users couldn't login because their UIDs were not included in the passwd map.

It is becoming more urgent to get this fixed.
Comment 13 Honza Horak 2011-04-29 02:58:41 EDT
*** Bug 700703 has been marked as a duplicate of this bug. ***
Comment 14 Honza Horak 2011-04-29 03:05:33 EDT
Created attachment 495722 [details]
proposed patch for specfile
Comment 15 Honza Horak 2011-04-29 03:20:40 EDT
Created attachment 495724 [details]
proposed patch for specfile

This patch corresponds with RHEL-6 spec. It uses %config(noreplace) for /etc/ypserv.conf, too.
Comment 16 Honza Horak 2011-07-12 11:10:33 EDT
*** Bug 465275 has been marked as a duplicate of this bug. ***
Comment 20 Honza Horak 2011-10-07 08:05:23 EDT
Committed to CVS, moving to modified.
http://post-office.corp.redhat.com/archives/cvs-commits-list/2011-October/msg01411.html
Comment 22 Honza Horak 2011-10-25 03:03:00 EDT
*** Bug 748584 has been marked as a duplicate of this bug. ***
Comment 24 errata-xmlrpc 2012-02-21 00:53:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0205.html

Note You need to log in before you can comment on or make changes to this bug.