Bug 481789 - I can't find file `pgflibrarytikzshadows.code'.
I can't find file `pgflibrarytikzshadows.code'.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 11:34 EST by Neal Becker
Modified: 2013-07-02 19:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:42:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2009-01-27 11:34:53 EST
Description of problem:

I d/l todonotes from ctan.  Tried to build it's example:
 latex todonotesexample.tex
....
(/usr/share/texmf/tex/generic/pgf/libraries/pgflibraryplothandlers.code.tex)
(/usr/share/texmf/tex/generic/pgf/libraries/pgflibrarytikztopaths.code.tex)))
! I can't find file `pgflibrarytikzshadows.code.tex'.
<argument> ...t pgflibrarytikz\pgf@temp .code.tex 
                                                  \catcode `\@ =\csname tikz...
l.113 
      

Looks like something is missing?

 rpm -qf /usr/share/texmf/tex/generic/pgf/libraries/pgflibrarytikztopaths.code.tex 
texlive-texmf-2007-26.fc10.noarch

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Niemueller 2009-02-16 13:29:25 EST
You require a newer version than is currently available in Fedora. You need to upgrade your version of pgf. Install a newer pgf to your ~/texmf tree.
Comment 2 Shakthi Kannan 2009-09-08 01:50:58 EDT
I am trying to use pgf-umsld:
http://code.google.com/p/pgf-umlsd/
http://www.texample.net/tikz/examples/pgf-umlsd/

and I have also hit this error on Fedora 11.

$ rpm -qa | grep tex

texlive-2007-42.fc11.i586
tex-preview-11.85-8.fc11.noarch
texlive-texmf-dvips-2007-28.fc11.noarch
gettext-libs-0.17-12.fc11.i586
texlive-texmf-2007-28.fc11.noarch
texlive-texmf-fonts-2007-28.fc11.noarch
gettext-0.17-12.fc11.i586
gettext-devel-0.17-12.fc11.i586
texlive-texmf-errata-fonts-2007-6.fc11.noarch
libtextcat-2.2-6.fc11.i586
texlive-dvips-2007-42.fc11.i586
texlive-latex-2007-42.fc11.i586
texlive-texmf-errata-dvips-2007-6.fc11.noarch
texlive-utils-2007-42.fc11.i586
texlive-texmf-errata-2007-6.fc11.noarch
texlive-texmf-errata-latex-2007-6.fc11.noarch
texlive-texmf-latex-2007-28.fc11.noarch

I have also tried downloading the latest pgf-2.00 to ~ and have re-run 'texhash'. Yet, I get the same error when I run pgf-umsld-0.4.tar.gz example code. 

Can you please confirm upgrading to which package fixes this error? Thanks!
Comment 3 Joe Sapp 2009-10-28 09:46:23 EDT
(In reply to comment #2)
> I have also tried downloading the latest pgf-2.00 to ~ and have re-run
> 'texhash'. Yet, I get the same error when I run pgf-umsld-0.4.tar.gz example
> code. 
> 
> Can you please confirm upgrading to which package fixes this error? Thanks!  

Like comment #1 says, install pgf to your ~/texmf tree as in the "Installation and Configuration" section in the pgf manual.  It doesn't look like there's any official Fedora package that can be installed through a package manager.
Comment 4 Bug Zapper 2009-11-18 04:09:23 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-12-18 02:42:37 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.