Bug 48201 - Informix error: 908: Attempt to connect to database server
Informix error: 908: Attempt to connect to database server
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-09 18:09 EDT by Isaac Salsberg
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 11:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Isaac Salsberg 2001-07-09 18:09:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I have problems receiving connections with  Informix IDS 7.30 (Informix 
Dynamic Server Version 7.30.U) running under Red-Hat 7.1. With Red-hat 6.2 
it just worked fine.

I can stablish a connection to other IDS servers on the network running 
under Red-Hat 6.2 by instance. However the one running under Red-Hat 7.1 
does NOT accept any connection from any client through the network.

The client receives the message:
Running (aprox. 20 seconds) and later..
> 
>    908: Attempt to connect to database server (demo_ids) failed.
>  ISAM error:  record is locked.



How reproducible:
Always

Steps to Reproduce:
1. Configure IDS 7.3 to run and receive connections under Red-Hat 7.1
2. Start the Informix IDS server, running under Red-Hat 7.1
3. Try to connect to the IDS Server running under Red-Hat 7.1 from any 
client on the network
4. The connection is refused and the client receives:
  908: Attempt to connect to database server (svrcvca) failed.
ISAM error:  record is locked.
	

Actual Results:  The connection is refused and the client receives:

  908: Attempt to connect to database server (svrcvca) failed.
ISAM error:  record is locked.


Expected Results:   production@test

 sysmaster@test

 sysutils@test

 test@test


 Connected.

Additional info:

The funny thing is that the server running red-hat 7.1 is able to connect 
to itself or to any other IDS server running different OS. However the IDS 
server with red-hat 7.1 rejects all the external (clients on the network) 
connections.
Comment 1 Bill Nottingham 2001-07-09 18:32:24 EDT
I don't see how this is a sysvinit bug. Assigning to glibc, but you might get a
better answer talking to Informix.
Comment 2 Bill Nottingham 2001-07-09 18:39:53 EDT
You may also want to make sure that your 7.1 install is not running a firewall.
Comment 3 Isaac Salsberg 2001-07-09 20:38:44 EDT
The ipchains service (firewall) is disabled
Comment 4 Isaac Salsberg 2001-07-16 11:18:08 EDT
I found the cause of the problem:

Informix IDS reads the /etc/hosts file to attach the ip-address to
the INFORMIXSERVER, and the "Red-Hat 7.1 installer" links the "hostname" to the 
loopback in the /etc/hosts file, instead of create a new entry, as follows:

a) /etc/hosts file generated by the installer

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       miserver localhost.localdomain localhost

b) Fixed /etc/hosts file:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       localhost.localdomain localhost
192.168.0.33    miserver.localdomain miserver

So, this is not a glibc problem, it is an Installer proble.


Note You need to log in before you can comment on or make changes to this bug.