Bug 482739 - [RFE] update to rev 39421 or above
[RFE] update to rev 39421 or above
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: WebKit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 14:57 EST by Mamoru TASAKA
Modified: 2017-09-13 03:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-13 03:55:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-01-27 14:57:32 EST
Description of problem:
Coming kazehakase 0.5.7 uses webkit_web_navigation_action_get_reason()
or so which seems to be defined on WebKit rev 39421 and above:
http://svnsearch.org/svnsearch/repos/WEBKIT/search?revision=39421&showPaths=all&

Current Fedora WebKit-gtk-devel does not define this function (and
related structure)

Version-Release number of selected component (if applicable):
F-11/10/9 WebKit
Comment 1 Mamoru TASAKA 2009-01-28 12:07:54 EST
Well, I tried rev 40306 and
- compiles on F-11/9 (not tested on F-10)
- bison24.patch no longer needed (applied upstream)
- libtestnetscapeplugin.so no longer needed (upstream change)

- kazehakase works good with WebKit rev 40306
Comment 2 Mamoru TASAKA 2009-01-28 12:08:23 EST
(In reply to comment #1)
> - libtestnetscapeplugin.so no longer needed (upstream change)

this is "no longer installed"
Comment 3 Peter Gordon 2009-01-29 01:51:02 EST
I'll take care of this first thing after classes tomorrow. :)

Thanks.
Comment 4 Mamoru TASAKA 2009-01-30 10:07:28 EST
On rawhide with the newest WebKit (1.0.0-0.16.svn40351.fc11)
kazehakase-0.5.6-3.svn3598_trunk.fc11 compiles correctly

http://koji.fedoraproject.org/koji/buildinfo?buildID=80845

Note You need to log in before you can comment on or make changes to this bug.