Bug 482777 - Cannot find a source rpm for (...)
Cannot find a source rpm for (...)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 19:32 EST by Jeroen van Meeuwen
Modified: 2013-01-10 00:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 19:54:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen van Meeuwen 2009-01-27 19:32:10 EST
Description of problem:

Pungi:INFO: Download list: []
Pungi:INFO: Finished downloading packages.
Error: Cannot find a source rpm for perl-SOAP-Lite-0.710.07-2.fc10

Version-Release number of selected component (if applicable):

$ rpm -qv pungi
pungi-2.0.8-1.fc10.noarch

How reproducible:

sudo pungi -c /usr/share/spin-kickstarts/fedora-install-fedora.ks

Steps to Reproduce:
1. install pungi and spin-kickstarts
2. run pungi against fedora-install-fedora.ks
3.
  
Actual results:

Pungi:INFO: Finished downloading packages.
Pungi:INFO: Download list: []
Pungi:INFO: Finished downloading packages.
Error: Cannot find a source rpm for perl-SOAP-Lite-0.710.07-2.fc10

==

$ yumdownloader --source perl-SOAP-Lite
Loaded plugins: fastestmirror, fedorakmod, kernel-module, protectbase, refresh-
              : packagekit, versionlock
Reading version lock configuration
0 packages excluded due to repository protections
Enabling fedora-10-rpmfusion-free-updates-source repository
Reading version lock configuration
0 packages excluded due to repository protections
Enabling fedora-10-rpmfusion-nonfree-updates-source repository
Reading version lock configuration
0 packages excluded due to repository protections
Enabling fedora-10-rpmfusion-free-source repository
Reading version lock configuration
0 packages excluded due to repository protections
Enabling fedora-10-updates-source repository
Reading version lock configuration
0 packages excluded due to repository protections
Enabling fedora-10-source repository
Reading version lock configuration
0 packages excluded due to repository protections
Enabling fedora-10-rpmfusion-nonfree-source repository
Reading version lock configuration
0 packages excluded due to repository protections
perl-SOAP-Lite-0.710.07-2.fc10.src.rpm                  | 726 kB     00:00     

==

$ grep ^repo /usr/share/spin-kickstarts/fedora-install-fedora.ks 
repo --name=fedora-10-everything --baseurl=http://www.kanarip.com/fedora/releases/10/Everything/$basearch/os/
repo --name=fedora-10-updates  --baseurl=http://www.kanarip.com/fedora/updates/10/$basearch/
repo --name=fedora-10-anaconda-updates  --baseurl=http://www.kanarip.com/anaconda/f10/$basearch/

==

$ find /data/os/distr/fedora/ -name "perl-SOAP-Lite*src.rpm"
/data/os/distr/fedora/development/source/SRPMS/perl-SOAP-Lite-0.710.08-1.fc11.src.rpm
/data/os/distr/fedora/releases/9/Everything/source/SRPMS/perl-SOAP-Lite-0.68-6.fc9.src.rpm
/data/os/distr/fedora/releases/8/Everything/source/SRPMS/perl-SOAP-Lite-0.68-5.fc8.src.rpm
/data/os/distr/fedora/releases/10/Fedora/source/SRPMS/perl-SOAP-Lite-0.710.07-2.fc10.src.rpm
/data/os/distr/fedora/releases/10/Everything/source/SRPMS/perl-SOAP-Lite-0.710.07-2.fc10.src.rpm
/data/os/distr/fedora/releases/7/Everything/source/SRPMS/perl-SOAP-Lite-0.68-2.fc6.src.rpm
/data/os/distr/fedora/updates/9/SRPMS.newkey/perl-SOAP-Lite-0.710.07-1.fc9.src.rpm
/data/os/distr/fedora/updates/8/SRPMS.newkey/perl-SOAP-Lite-0.710.07-1.fc8.src.rpm
Comment 1 Jesse Keating 2009-01-27 19:54:10 EST
erm, you haven't fed pungi any repos that would actually point to the source packages, so how could pungi find the source packages?
Comment 2 Jeroen van Meeuwen 2009-01-28 14:15:23 EST
Where do I configure pungi to not use or require the apparent mandatory source repositories, if at all possible?
Comment 3 Jesse Keating 2009-01-28 14:30:01 EST
--nosource  is the documented flag to tell pungi not to do source gathering.  Also of interest, --nodebuginfo, although I'm considering flipping that so that you have to explicitly ask for debuginfo.

Note You need to log in before you can comment on or make changes to this bug.