Bug 482799 - qpidd broker command-line parameter parser / start-up bug (critical Broker start-up failed: If --data-dir is blank or --no-data-dir is specified, --store-dir must be present.)
qpidd broker command-line parameter parser / start-up bug (critical Broker st...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
urgent Severity urgent
: 1.1.1
: ---
Assigned To: messaging-bugs
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 04:26 EST by Frantisek Reznicek
Modified: 2015-11-15 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 12:01:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Reznicek 2009-01-28 04:26:19 EST
Description of problem:

The qpidd broker does not start-up properly. 
qpidd claims that 
2009-jan-28 04:05:09 critical Broker start-up failed: If --data-dir is blank or --no-data-dir is specified, --store-dir must be present.

and exits with exit code 1

Both manual and service launch way tested, both fail (see Additional info for details).
This is bug which unfortunately prevents further testing (TestBlocker).

Version-Release number of selected component (if applicable):
qpidd-0.4.738274-1.el5, rhm-0.4.3075-2.el5

How reproducible:
100%

Steps to Reproduce:
1. mkdir data
2. qpidd -p 5672 --auth no --log-enable info+ --data-dir ${PWD}/data
3. echo $? and see transcript
  
Actual results:
qpidd does not start-up.

Expected results:
qpidd should start-up correctly.

Additional info (detailed transcript):

[root@nec-em13 qpid_test_common_mrg_install]# mkdir data
You have new mail in /var/spool/mail/root
[root@nec-em13 qpid_test_common_mrg_install]# qpidd -p 5672 --auth no --log-enable info+ --data-dir ${PWD}/data
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/replication_exchange.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/xml.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/ssl.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/replicating_listener.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/client/rdmaconnector.so
2009-jan-28 04:05:09 info SSL connector not enabled, you must set QPID_SSL_CERT_DB to enable it.
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/client/sslconnector.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/cluster.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/acl.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/rdma.so
2009-jan-28 04:05:09 info Loaded Module: /usr/lib/qpid/daemon/msgstore.so
2009-jan-28 04:05:09 info Management enabled
2009-jan-28 04:05:09 info ManagementBroker generated broker ID: 87a8a286-c5cd-4533-a7fe-50028273fde9
2009-jan-28 04:05:09 critical Broker start-up failed: If --data-dir is blank or --no-data-dir is specified, --store-dir must be present.
[root@nec-em13 qpid_test_common_mrg_install]# echo $?
1
[root@nec-em13 qpid_test_common_mrg_install]# service qpidd start
Starting Qpid AMQP daemon: Daemon startup failed: If --data-dir is blank or --no-data-dir is specified, --store-dir must be present.
[FAILED]
[root@nec-em13 qpid_test_common_mrg_install]# echo $?
1
Comment 1 Kim van der Riet 2009-01-28 08:53:08 EST
This build of rhm is bad; because of bad tagging of qpidc, it built against the incorrect version of qpidc, so there is a binary mismatch.

Setting NEEDINFO; verify that this problem still exists with new build of rhm packages or set to CLOSED/NOTABUG.
Comment 2 Kim van der Riet 2009-01-28 09:19:28 EST
Please test against rhm-0.4.3075-3.el5 and rhm-0.4.3075-3.el4.
Comment 3 Frantisek Reznicek 2009-01-28 12:01:36 EST
Bad rhm build confirmed.

->CLOSED [NOTABUG]

Note You need to log in before you can comment on or make changes to this bug.