Bug 482800 - i386 versions of openssl097a and compat-readline43 for x86_64 channel
i386 versions of openssl097a and compat-readline43 for x86_64 channel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Mach
Alexander Todorov
:
: 441993 475262 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 04:30 EST by Tomas Smetana
Modified: 2010-10-23 03:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 08:01:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Smetana 2009-01-28 04:30:06 EST
Can we please provide the i386 versions of openssl097a and compat-readline43 packages in the x86_64 channel?  These are both compat packages whose "regular" variants are being shipped as multilib already.

I have talked to the openssl maintainer and he sees no problem in this.  I will ask also the readline maintainer but the package looks like there don't seem to be any issues too.
Comment 1 Tomas Smetana 2009-01-28 07:35:51 EST
The readline maintainer sees no problem with providing the compat package as multilib.
Comment 2 Daniel Mach 2009-01-28 08:30:12 EST
Both openssl097a and compat-readline43 look good and could be used as multilib.
I've checked that they don't have any special dependencies and can be installed on a rhel5 boxwithout requiring any other packages.

We can add these packages to distill config to make them multilib.
If the change is needed before 5.4, we could push it to rhn:
a) manually
b) via an errata

I'd prefer b) to ensure at least minimal testing and customers would be notified about the change.
Comment 4 Jeremy West 2009-02-04 10:17:48 EST
*** Bug 475262 has been marked as a duplicate of this bug. ***
Comment 6 Dennis Gregorovic 2009-06-01 08:09:25 EDT
Change checked into distill and will appear in the next compose.
Comment 8 Alexander Todorov 2009-06-19 08:00:06 EDT
with today's nightly/x86_64

$ ls -1 openssl097a* compat-readline43*
compat-readline43-4.3-3.i386.rpm
compat-readline43-4.3-3.x86_64.rpm
openssl097a-0.9.7a-9.el5_2.1.i386.rpm
openssl097a-0.9.7a-9.el5_2.1.x86_64.rpm

Requested packages are now multi-lib. Moving to VERIFIED.
Comment 10 Chris Van Hoof 2009-08-14 14:56:11 EDT
*** Bug 441993 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2009-09-02 08:01:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1400.html

Note You need to log in before you can comment on or make changes to this bug.