Bug 48281 - sendmail fails to validate users home directory on checking for .forward
Summary: sendmail fails to validate users home directory on checking for .forward
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-10 00:55 UTC by Ben LaHaise
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 14:35:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben LaHaise 2001-07-10 00:55:01 UTC
In more complicated system setups where /home is mounted via NFS, sendmail
fails to check  for the existence of the user's home directory when
checking if a .forward file exists.  This causes misdelivery of mail when
there is a temporary problem with the home directory (eg if the NFS server
is offline).  A suitable fix should involve checking that the home
directory exists and is readable on failure to open ~/.forward.

Comment 1 David Woodhouse 2001-07-11 12:38:37 UTC
The suggested fix is implemented and works fine in Exim and Postfix.


Comment 2 Ben LaHaise 2001-09-26 21:48:47 UTC
Is anything being done about this?

Comment 3 Florian La Roche 2002-04-07 13:56:25 UTC
sendmail itself does not do any local mail delivery. Our default local
delivery is procmail, so I re-assign to this component in bugzilla.

Florian La Roche


Comment 4 Ben LaHaise 2002-04-07 21:20:10 UTC
procmail does not perform .forward parsing.  Reassigned to sendmail.

Comment 5 Thomas Woerner 2004-10-21 14:35:38 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.