Bug 482887 - Values in new cf_partner field are getting reset
Values in new cf_partner field are getting reset
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.2
All Linux
low Severity urgent (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 12:46 EST by Andrius Benokraitis
Modified: 2015-07-14 00:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 11:51:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 to fix problem with resetting partner and verified fields (7.76 KB, patch)
2009-01-29 09:47 EST, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Andrius Benokraitis 2009-01-28 12:46:32 EST
I've experienced two separate cases of values set in cf_partner being reset from a partner back to Any. The first was IBM and the second QLogic. In both cases the user had not explicitly reset the field. I have one here, and I'll try to dig up the second instance...

In this case all the person did was change NEW to ASSIGNED.

-------- Original Message --------
Subject: [Bug 481691] [QLogic 5.4 bug] qla2xx - Word-endian problem
programming flash on PPC
Date: Wed, 28 Jan 2009 11:16:22 -0500
From: bugzilla@redhat.com
To: andriusb@redhat.com
References: <bug-481691-154848@bugzilla.redhat.com>

Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=481691


Marcus Barrow <mbarrow@redhat.com> changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
           Partner|Qlogic                      |
            Status|NEW                         |ASSIGNED
           Partner|Any                         |
Comment 1 Andrius Benokraitis 2009-01-28 12:50:09 EST
Found the second case... in this case all that was done was a user added themselves to the bug in the CC field and the Partner field was reset.

https://bugzilla.redhat.com/show_bug.cgi?id=480204


Richard A Lary <rlary@us.ibm.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Partner|Qlogic                      |
                 CC|                            |rlary@us.ibm.com
            Partner|Any                         |
Comment 2 David Lawrence 2009-01-28 12:54:26 EST
Giving to Noura.
Comment 3 Noura El hawary 2009-01-29 09:47:25 EST
Created attachment 330359 [details]
v1 to fix problem with resetting partner and verified fields

Basically the problem is coming from the logic within the process_custom_field extension, I have fixed the logic, also the patch includes the following:

- I have moved out the redhat group check from the function can_see_partner, and renamed it can_set_partner, as the members of only the redhat group can just view the partner fields and they cant write or edit it so viewing is basically separate to most functionality that will be required to edit/write the fields so i separated it.

- I have added a fix to the column name of changed fields that appears in email notifications as i noticed that for both cf_verified and cf_partner changes the email had the name "Partner" so i changed that to be either Patner or Verified.

Noura
Comment 4 Chris Ward 2009-01-29 10:00:56 EST
> - I have added a fix to the column name of changed fields that appears in email
> notifications as i noticed that for both cf_verified and cf_partner changes the
> email had the name "Partner" so i changed that to be either Patner or Verified.
> 

^^^
I think this is the problem, because when a new partner is selected, the Verified field /should/ be automatically set to 'Any'. Partner field doesn't even have a 'Any' value. So it does seem when the email said 'Partner' it actually meant 'Verified'
Comment 5 Noura El hawary 2009-01-29 10:05:52 EST
(In reply to comment #4)
> > - I have added a fix to the column name of changed fields that appears in email
> > notifications as i noticed that for both cf_verified and cf_partner changes the
> > email had the name "Partner" so i changed that to be either Patner or Verified.
> > 
> 
> ^^^
> I think this is the problem, because when a new partner is selected, the
> Verified field /should/ be automatically set to 'Any'. Partner field doesn't
> even have a 'Any' value. So it does seem when the email said 'Partner' it
> actually meant 'Verified'

Yes you are right chris, a fix for that is included in the attached patch,

Also please note that this fix is now applied to bz-web2 for testing if needed.

Dave, if the patch looks good to you, please commit to cvs so we can include it in package that will be pushed today.

Thanks,
Noura
Comment 6 David Lawrence 2009-01-29 11:29:54 EST
Comment on attachment 330359 [details]
v1 to fix problem with resetting partner and verified fields

Looks good Noura.
Dave
Comment 7 Noura El hawary 2009-01-29 11:51:00 EST
(In reply to comment #6)
> (From update of attachment 330359 [details])
> Looks good Noura.
> Dave

Thanks for the review Dave, all committed now to cvs

Noura

Note You need to log in before you can comment on or make changes to this bug.