Bug 482891 - ximtoppm segfaults
ximtoppm segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On: 482867
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 13:10 EST by Jindrich Novy
Modified: 2013-07-02 19:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 482867
Environment:
Last Closed: 2009-01-28 13:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ximtoppm segfault fix (672 bytes, patch)
2009-01-28 13:27 EST, Jindrich Novy
no flags Details | Diff

  None (edit)
Description Jindrich Novy 2009-01-28 13:10:57 EST
+++ This bug was initially created as a clone of Bug #482867 +++

Created an attachment (id=330244)
strace output

Description of problem:
When I run the utility without parameters it segfaults.

Version-Release number of selected component (if applicable):
netpbm-progs-10.35-6.1.el5_2.2

How reproducible:
always

Steps to Reproduce:
# ximtoppm 
Segmentation fault
  
Actual results:
The utility segfaults

Expected results:
The utility does not segfault.

Additional info:

--- Additional comment from mmalik@redhat.com on 2009-01-28 11:31:29 EDT ---

Created an attachment (id=330245)
ltrace output

--- Additional comment from mmalik@redhat.com on 2009-01-28 11:41:10 EDT ---

The package netpbm-progs-10.35.54-1.fc10 in Fedora 10 is also affected.
Comment 1 Jindrich Novy 2009-01-28 13:27:40 EST
Created attachment 330268 [details]
ximtoppm segfault fix

The utility couldn't have ever worked as it lacks command line parsing initialization code. This patch fixes it.
Comment 2 Jindrich Novy 2009-01-28 13:28:56 EST
It is now fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.