Bug 482917 - RHN-Proxy-5.3.0-RHEL5-re20090127.2: unresolved dependencies
RHN-Proxy-5.3.0-RHEL5-re20090127.2: unresolved dependencies
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Release (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
:
: 482914 (view as bug list)
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-01-28 14:50 EST by Milan Zázrivec
Modified: 2009-09-10 10:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:37:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
repoclosure output (6.92 KB, text/plain)
2009-01-28 14:50 EST, Milan Zázrivec
no flags Details

  None (edit)
Description Milan Zázrivec 2009-01-28 14:50:43 EST
Created attachment 330277 [details]
repoclosure output

Description of problem:
Repoclosure test for RHN-Proxy-5.3.0-RHEL5-re20090127.2 reports several
unresolved dependencies (same output for all arches) -> compose won't
install.
Comment 1 Miroslav Suchý 2009-01-30 11:02:31 EST
Reported to rel-eng as #34573
Comment 2 Miroslav Suchý 2009-01-30 11:03:43 EST
For the record:

  unresolved deps: 
     spacewalk-certs-tools
     spacewalk-ssl-cert-check
package: spacewalk-proxy-installer-0.5.4-1.el5sat.noarch from http://porkchop.devel.redhat.com/devel/candidate-trees/RHN-Proxy-5.3.0-RHEL5-re20090127.2/i386/i386/RHNProxy/
  unresolved deps: 
     rhncfg-management
     rhncfg-client
     rhncfg
     rhncfg-actions

These packages should be in RHN tools channel so this errors will be there always.
Comment 3 Miroslav Suchý 2009-02-04 05:01:27 EST
*** Bug 482914 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Suchý 2009-02-09 04:51:10 EST
Ticket has been resolved.
Comment 5 Miroslav Suchý 2009-02-17 04:32:14 EST
Ohh, I find that the ticket has been resolved only partialy.
Comment 6 Miroslav Suchý 2009-02-23 03:58:14 EST
Ticket is still not resolved (been done wrongly). Keeping modified.
Comment 7 Miroslav Suchý 2009-03-09 09:15:59 EDT
Mass moving to ON_QA
Comment 9 John Matthews 2009-08-07 13:25:43 EDT
Move to RELEASE_PENDING

[root@dhcp77-237 ~]# yum install spacewalk-proxy-installer
Loaded plugins: rhnplugin, security
rhel-i386-server-5                                                                                                        | 1.3 kB     00:00     
primary.xml.gz                                                                                                            | 2.1 MB     00:00     
rhel-i386-server-5                                             5580/5580
rhn-tools-rhel-i386-server-5                                                                                                                                              |  871 B     00:00     
primary.xml.gz                                                                                                                                                            |  33 kB     00:00     
rhn-tools-rhel-i386-server-5                                   416/416
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package spacewalk-proxy-installer.noarch 0:0.5.25-17.el5sat set to be updated
--> Processing Dependency: rhncfg-actions for package: spacewalk-proxy-installer
--> Processing Dependency: rhncfg-management for package: spacewalk-proxy-installer
--> Processing Dependency: rhncfg for package: spacewalk-proxy-installer
--> Processing Dependency: rhncfg-client for package: spacewalk-proxy-installer
--> Processing Dependency: libxslt for package: spacewalk-proxy-installer
--> Running transaction check
---> Package rhncfg-actions.noarch 0:5.9.5-3.el5sat set to be updated
---> Package rhncfg-client.noarch 0:5.9.5-3.el5sat set to be updated
---> Package libxslt.i386 0:1.1.17-2.el5_2.2 set to be updated
---> Package rhncfg.noarch 0:5.9.5-3.el5sat set to be updated
---> Package rhncfg-management.noarch 0:5.9.5-3.el5sat set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================
 Package                                 Arch                 Version                           Repository                                  Size
=================================================================================================================================================
Installing:
 spacewalk-proxy-installer               noarch               0.5.25-17.el5sat                  rhn-tools-rhel-i386-server-5                46 k
Installing for dependencies:
 libxslt                                 i386                 1.1.17-2.el5_2.2                  rhel-i386-server-5                         485 k
 rhncfg                                  noarch               5.9.5-3.el5sat                    rhn-tools-rhel-i386-server-5                58 k
 rhncfg-actions                          noarch               5.9.5-3.el5sat                    rhn-tools-rhel-i386-server-5                28 k
 rhncfg-client                           noarch               5.9.5-3.el5sat                    rhn-tools-rhel-i386-server-5                24 k
 rhncfg-management                       noarch               5.9.5-3.el5sat                    rhn-tools-rhel-i386-server-5                34 k

Transaction Summary
=================================================================================================================================================
Install      6 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 676 k
Is this ok [y/N]: y
Downloading Packages:
(1/6): rhncfg-client-5.9.5-3.el5sat.noarch.rpm                                                                                                                            |  24 kB     00:00     
(2/6): rhncfg-actions-5.9.5-3.el5sat.noarch.rpm                                                                                                                           |  28 kB     00:00     
(3/6): rhncfg-management-5.9.5-3.el5sat.noarch.rpm                                                                                                                        |  34 kB     00:00     
(4/6): spacewalk-proxy-installer-0.5.25-17.el5sat.noarch.rpm                                                                                                              |  46 kB     00:00     
(5/6): rhncfg-5.9.5-3.el5sat.noarch.rpm                                                                                                                                   |  58 kB     00:00     
(6/6): libxslt-1.1.17-2.el5_2.2.i386.rpm                                                                                                                                  | 485 kB     00:00     
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                            568 kB/s | 676 kB     00:01     
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 37017186
Importing GPG key 0x37017186 "Red Hat, Inc. (release key) <security@redhat.com>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : libxslt                                           [1/6] 
  Installing     : rhncfg                                            [2/6] 
  Installing     : rhncfg-client                                     [3/6] 
  Installing     : rhncfg-actions                                    [4/6] 
  Installing     : rhncfg-management                                 [5/6] 
  Installing     : spacewalk-proxy-installer                         [6/6] 

Installed: spacewalk-proxy-installer.noarch 0:0.5.25-17.el5sat
Dependency Installed: libxslt.i386 0:1.1.17-2.el5_2.2 rhncfg.noarch 0:5.9.5-3.el5sat rhncfg-actions.noarch 0:5.9.5-3.el5sat rhncfg-client.noarch 0:5.9.5-3.el5sat rhncfg-management.noarch 0:5.9.5-3.el5sat
Complete!
Comment 10 Brandon Perkins 2009-09-10 10:37:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.