Bug 482926 - 5.3 proxy install via web gui fails with ISE
5.3 proxy install via web gui fails with ISE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Preethi Thomas
:
: 485079 (view as bug list)
Depends On: 485143 486054 491687
Blocks: 456999 486216
  Show dependency treegraph
 
Reported: 2009-01-28 15:46 EST by Shannon Hughes
Modified: 2009-09-10 10:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Hughes 2009-01-28 15:46:02 EST
Description of problem:

when installing proxy via the 5.3 sat gui it throws a ISE when activating system as proxy. 

[Wed Jan 28 10:18:52 2009] [error] Execution of /var/www/html/network/systems/details/proxy/index.pxt failed at Wed Jan 28 10:18:52 2009: /var/www/html//applications/rhn-proxy/5.3/install-rhn-proxy.xml:622: parser error : Opening and ending tag mismatch: run-script line 597 and schedule-actions\n    </schedule-actions>\n                       ^\n at /usr/lib/perl5/site_perl/5.8.8/RHN/AppInstall/Parser.pm line 55
[Wed Jan 28 10:19:05 2009] [error] Traceback sent to rhn-traffic@redhat.com at /usr/lib/perl5/site_perl/5.8.8/PXT/ApacheHandler.pm line 729.

iso Satellite-5.3.0-RHEL5-re20090127.2-i386-embedded-oracle.iso
Comment 1 Shannon Hughes 2009-01-28 16:25:43 EST
looks like install-rhn-proxy.xml needs version bumped as well as checked for xml validation. i noticed many tags that did not have corresponding end tags or end tags stuck at random. did a merge conflict cause this?
Comment 2 Miroslav Suchý 2009-01-29 10:04:24 EST
Version is fixed in commit 334e0527de4b97d233fc5d79c74dea8140545701
Validity of XML is fixed in 11addda9a39c8f08abdfa40f2f3b831b3a6bdd79
Now the installer proceed but did not subscribe to proxy channel, but that I will fill as different bug.
Comment 3 Preethi Thomas 2009-02-11 12:15:43 EST
select 5.3 to activate proxy 
- browser spins and then completes
- no status message is displayed
Comment 4 Clifford Perry 2009-02-11 13:23:05 EST
Assigning to Shannon since I know he is looking at this today. Shannon - QA would love this to be available for this Friday's ISO.
Comment 5 Shannon Hughes 2009-02-11 15:04:25 EST
*** Bug 485079 has been marked as a duplicate of this bug. ***
Comment 6 Shannon Hughes 2009-02-11 15:07:25 EST
install-rhn-proxy.xml was referencing an obsolete package. got past the spinning. 

was not able to go through a complete proxy install due to the dependency errors in the proxy channel for rhncfg, rhncfg-actions and rhncfg-client.
Comment 7 Shannon Hughes 2009-02-11 15:32:47 EST
full proxy install depends on 485143
Comment 8 Preethi Thomas 2009-03-17 14:14:03 EDT
fails-qa
webui proy install fails with ssl generation error

Could not Generate SSL server cert. Error: 1
Comment 9 Shannon Hughes 2009-03-18 10:16:02 EDT
I got this to work by turning off selinux and modifying the rhn_web.conf file to force proxy channel subscription. 

these tests are on the 3/6 iso. going to let preethi test with the st patrick's day iso to see if this fixes the issue. 

if selinux is a problem then we will need to open a bug that blocks this one.
Comment 10 Preethi Thomas 2009-03-23 10:58:07 EDT
fails_qa
looks like its the selinux. works  with selinux disabled
Comment 11 Miroslav Suchý 2009-03-23 11:19:45 EDT
Would you mind to attach you audit.log?
Comment 12 Preethi Thomas 2009-03-23 13:24:16 EDT
from audit. log


type=AVC msg=audit(1237825098.946:50): avc:  denied  { sys_resource } for 
pid=3791 comm="sudo" capability=24 scontext=system_u:system_r:httpd_t:s0
tcontext=system_u:system_r:httpd_t:s0 tclass=capability
type=SYSCALL msg=audit(1237825098.946:50): arch=40000003 syscall=75 success=no
exit=-1 a0=6 a1=bfc04bf0 a2=253ff4 a3=bfc04bf0 items=0 ppid=2756 pid=3791
auid=4294967295 uid=48 gid=48 euid=0 suid=0 fsuid=0 egid=48 sgid=48 fsgid=48
tty=(none) ses=4294967295 comm="sudo" exe="/usr/bin/sudo"
subj=system_u:system_r:httpd_t:s0 key=(null)
type=AVC msg=audit(1237825099.019:51): avc:  denied  { create } for  pid=3791
comm="sudo" scontext=system_u:system_r:httpd_t:s0
tcontext=system_u:system_r:httpd_t:s0 tclass=netlink_audit_socket
type=SYSCALL msg=audit(1237825099.019:51): arch=40000003 syscall=102 success=no
exit=-13 a0=1 a1=bfc04a90 a2=397ff4 a3=6db0a0 items=0 ppid=2756 pid=3791
auid=4294967295 uid=0 gid=48 euid=0 suid=0 fsuid=0 egid=48 sgid=48 fsgid=48
tty=(none) ses=4294967295 comm="sudo" exe="/usr/bin/sudo"
subj=system_u:system_r:httpd_t:s0 key=(null)
Comment 13 Miroslav Suchý 2009-03-24 04:51:22 EDT
The selinux issue is traced in different BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=491687
So this BZ should be verified id succeed without selinux enable. IMO.
Comment 14 Shannon Hughes 2009-03-24 09:59:22 EDT
we need to install the proxy anyway to test the selinux bug. i'll watch this bug and move to modified with the depending bug 491687 moves to modified. 

moving to assigned and i will take a AI for this.
Comment 15 Preethi Thomas 2009-04-02 09:25:04 EDT
verified 
Satellite-5.3.0-RHEL5-re20090327.0 
activated rhel4 proxy on rhel5 satellite from webui
Comment 16 Tomas Lestach 2009-09-08 06:14:07 EDT
Successful RHN Proxy installation. No issues, no ISEs, no avc denies.

Stage validated -> RELEASE_PENDING
Comment 17 Jan Pazdziora 2009-09-08 09:58:27 EDT
Stage validated with Satellite-5.3.0-RHEL5-re20090820.1. I've installed RHN Proxy on RHEL 4 and RHEL 5 via WebUI installer, from Satellite which had the Proxy channels synced from the channel dumps.

Moving to RELEASE_PENDING.
Comment 18 Brandon Perkins 2009-09-10 10:37:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.