Bug 482927 - attempt to virsh attach-disk of floppy doesn't work
attempt to virsh attach-disk of floppy doesn't work
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Other
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 15:54 EST by John Levon
Modified: 2010-05-25 12:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 12:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Levon 2009-01-28 15:54:54 EST
First, virsh disables attaches of type floppy. However, even then,
the xend driver doesn't work. Floppy disks appear in (image (hvm... section
not as a device, and the code only knows how to call device create,
which xend can't deal with floppies. Since attaching floppies only
makes sense in HVM, and that only works offline, the code should
attempt to re-define the entire domain in this case to attach
the floppy.
Comment 1 Daniel Berrange 2009-01-28 16:06:33 EST
Actually this should work in same way as for CDROMs. ie you can't hot attach an entire CDROM device, but you can change the existing media backing it.

Sadly, AFAICT XenD is unable to change floppy drive media even though QEMU itself supports this.
Comment 2 Cole Robinson 2010-05-25 12:01:07 EDT
The specific floppy check has been dropped from virsh.c, and the host hotplug vs. XML updating has been clarified with new explicit attach device APIs. Closing as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.