Bug 482977 - dbus: Can't send to audit system: USER_AVC avc: received policyload notice
dbus: Can't send to audit system: USER_AVC avc: received policyload notice
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 01:36 EST by Christopher Beland
Modified: 2013-03-05 22:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 11:47:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2009-01-29 01:36:00 EST
During a recent "yum update", I got an error from dbus:

Jan 24 14:57:42 free-spin yum: Updated: policycoreutils-gui-2.0.61-6.fc11.x86_64
Jan 24 14:58:03 free-spin dbus: Can't send to audit system: USER_AVC avc:  received policyload notice (seqno=4)#012: exe="?" (sauid=81, hostname=?, addr=?, terminal=?)
Jan 24 14:58:03 free-spin kernel: type=1403 audit(1232827083.073:8): policy loaded auid=500 ses=175
Jan 24 14:58:03 free-spin dbus: Reloaded configuration
Jan 24 14:58:05 free-spin yum: Updated: selinux-policy-targeted-3.6.3-8.fc11.noarch

I don't know if it makes a difference, but auditd wasn't running at the time due to an unrelated permissions problem.  Commenter at bug 481459 asked that this be reported separately under the dbus component.
Comment 1 Christopher Beland 2009-02-11 11:47:44 EST
With the auditd bug fixed, dbus no longer complains on update or startup.
Comment 2 Eddie Lania 2009-08-12 03:28:08 EDT
I just upgraded from fc10 to fc11 and now I am seeing similar messages in the syslog:

Aug 12 08:26:11 ls2ka dbus: avc:  received policyload notice (seqno=4)
Aug 12 08:26:11 ls2ka dbus: Can't send to audit system: USER_AVC avc:  received policyload notice (seqno=4)#012: exe="?" (sauid=81, hostname=?, addr=?, terminal=?)

The auditd is running tough.

Can this be fixed?
Comment 3 Mike Rubel 2009-09-24 00:22:27 EDT
I am also seeing this one on a fairly stock Fedora 11 system, updated with all current patches as of today.  The messages are of identical form: dbus: Can't send to audit system: USER_AVC avc: received policyload notice ... (etc) in /var/log/messages.

Auditd seems to be working fine in other respects, as /var/log/audit/audit.log is being populated.  Has there been a dbus regression?

Note You need to log in before you can comment on or make changes to this bug.