Bug 482986 - missing default answers.txt file in the re20090127.2 install tree
missing default answers.txt file in the re20090127.2 install tree
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Dennis Gilmore
Jan Hutař
:
: 483081 (view as bug list)
Depends On:
Blocks: 463876 486216
  Show dependency treegraph
 
Reported: 2009-01-29 02:37 EST by Jan Hutař
Modified: 2009-09-10 14:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:14:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-01-29 02:37:51 EST
Description of problem:
I'm missing default answers.txt file in the re20090127.2 install tree - it used to be in the install/ subdirectory. If that is expected, please suggest new location of the default install file.


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090127.2


How reproducible:
always


Steps to Reproduce:
1. $ ls /mnt/redhat/devel/candidate-trees/Satellite-5.3.0-RHEL5-re20090127.2/i386/i386/install


Actual results:
lib


Expected results:
there used to be much more files
Comment 1 Brandon Perkins 2009-01-29 17:35:26 EST
*** Bug 483081 has been marked as a duplicate of this bug. ***
Comment 2 Jan Pazdziora 2009-01-30 12:54:24 EST
FYI, this was handled with release engineering via ticket https://engineering.redhat.com/rt3/Ticket/Display.html?id=34520

This bugzilla should now be MODIFIED.
Comment 3 Dave Parker 2009-02-03 12:20:47 EST
I mis-understood the meaning of "ASSIGNED" - moving back to MODIFIED
Comment 4 Dave Parker 2009-02-03 13:24:48 EST
Jan - reassigning to you as you did the work on it.
Comment 5 Clifford Perry 2009-02-18 16:32:15 EST
ON_QA by mistake. Sorry - miss-read bug history.
Comment 7 Jesus M. Rodriguez 2009-02-18 17:22:11 EST
answers.txt files lives in the root of the iso.
Comment 8 Jan Hutař 2009-02-23 04:53:16 EST
Hello,
why it is now in the root of the iso? In 520 it was in the install/ subdir. Is this change expected?

Regards,
Jan
Comment 9 Jesus M. Rodriguez 2009-02-28 20:36:22 EST
Because no one told rel-eng where it belongs, and it got placed in the root.
I don't see it as a problem, but if it really bothers folks we can move it to the
install directory.

Frankly, I don't care where it goes, and it's just as easy to change.
Comment 11 Dennis Gilmore 2009-02-28 23:34:28 EST
cvs diff -u
cvs diff: Diffing .
Index: satellite-5.3-rhel4.conf
===================================================================
RCS file: /cvs/rel-eng/distill/configfiles/Attic/satellite-5.3-rhel4.conf,v
retrieving revision 1.1.2.12
diff -u -r1.1.2.12 satellite-5.3-rhel4.conf
--- satellite-5.3-rhel4.conf	30 Jan 2009 17:24:53 -0000	1.1.2.12
+++ satellite-5.3-rhel4.conf	1 Mar 2009 04:33:49 -0000
@@ -7,7 +7,7 @@
 tree_context_embeddeddb_comps_file = 'comps/comps-rhel4-rhnsat53-embeddeddb.xml'
 
 extra_files = [ {'gitroot': 'git://git.rhndev.redhat.com/satellite',\
-                 'files' : ['install.pl', 'README', 'answers.txt'],\
+                 'files' : ['install.pl', 'README'],\
                  'path' : 'SATELLITE-5.3:satellite/install',\
                 },\
                 {'gitroot': 'git://git.rhndev.redhat.com/satellite',\
@@ -19,7 +19,7 @@
                  'path' : 'SATELLITE-5.3:spacewalk/setup/lib/Spacewalk',\
                  'target': 'install/lib/Spacewalk'},\
                 {'gitroot': 'git://git.rhndev.redhat.com/satellite',\
-                 'files' : ['installPackages.py', 'rhn_rpm.py', 'satErrors.py', 'satLog.py', 'translate.py'],\
+                 'files' : ['installPackages.py', 'rhn_rpm.py', 'satErrors.py', 'satLog.py', 'translate.py', 'answers.txt'],\
                  'path' : 'SATELLITE-5.3:satellite/install/',\
                  'target': 'install'},\
                 {'cvsroot': ':pserver:anonymous@cvs.devel.redhat.com:/cvs/devel',\
Index: satellite-5.3-rhel5.conf
===================================================================
RCS file: /cvs/rel-eng/distill/configfiles/Attic/satellite-5.3-rhel5.conf,v
retrieving revision 1.1.2.10
diff -u -r1.1.2.10 satellite-5.3-rhel5.conf
--- satellite-5.3-rhel5.conf	30 Jan 2009 17:24:53 -0000	1.1.2.10
+++ satellite-5.3-rhel5.conf	1 Mar 2009 04:33:49 -0000
@@ -7,9 +7,13 @@
 tree_context_embeddeddb_comps_file = 'comps/comps-rhel5-rhnsat53-embeddeddb.xml'
 
 extra_files = [ {'gitroot': 'git://git.rhndev.redhat.com/satellite',\
-                 'files' : ['install.pl', 'README', 'answers.txt'],\
+                 'files' : ['install.pl', 'README'],\
                  'path' : 'SATELLITE-5.3:satellite/install',\
                 },\
+		{'gitroot': 'git://git.rhndev.redhat.com/satellite',\
+                 'files' : ['answers.txt'],\
+                 'path' : 'SATELLITE-5.3:satellite/install',\
+                 'target': 'install/'},\
                 {'gitroot': 'git://git.rhndev.redhat.com/satellite',\
                  'files' : ['Validate.pm', 'ValidatePP.pm'],\
                  'path' : 'SATELLITE-5.3:satellite/install/lib/Params',\


will be changed with next weeks compose
Comment 12 Jan Hutař 2009-03-17 03:57:54 EDT
Thank you - VERIFIED on Satellite-5.3.0-RHEL{4,5}-re20090313.0-{i386,x86_64} trees.
Comment 13 Miroslav Suchý 2009-08-19 10:11:57 EDT
[root@xen5 Satellite-5.3.0-RHEL5-re20090817.0-i386]# ls -l ./install/answers.txt
-rw-r--r-- 2 13396 13396 3200 Aug 17 21:17 ./install/answers.txt
[root@xen5 Satellite-5.3.0-RHEL5-re20090817.0-i386]# cd ../Satellite-5.3.0-RHEL5-re20090817.0-x86_64/
[root@xen5 Satellite-5.3.0-RHEL5-re20090817.0-x86_64]# ls -l ./install/answers.txt
-rw-r--r-- 2 13396 13396 3200 Aug 17 21:17 ./install/answers.txt

verfified in stage
Comment 14 Brandon Perkins 2009-09-10 14:14:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.