Bug 483048 - Traceback while testing updates=notext.img
Traceback while testing updates=notext.img
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:bac140b7bb0ecc8d3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 09:32 EST by James Laska
Modified: 2013-09-02 02:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 11:43:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (74.38 KB, text/plain)
2009-01-29 09:32 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-01-29 09:32:55 EST
This bug was filed automatically by anaconda.
Comment 1 James Laska 2009-01-29 09:32:59 EST
Created attachment 330356 [details]
Attached traceback automatically from anaconda.
Comment 2 Martin Sivák 2009-02-02 06:40:00 EST
Hi,

James, can you give us the updates image too please? Because it tracebacks in it and I do not have the code for it.

Thanks
Comment 3 James Laska 2009-02-02 09:48:21 EST
msivak: 

Sure ... updates=http://clumens.fedorapeople.org/notext.img
Comment 4 Chris Lumens 2009-02-03 14:32:38 EST
The problem here is that because the kickstart file contains no packages section, anaconda wants to stop and show the package selection UI.  That's how kickstart works - missing sections mean stop and ask for input.  However, this step no longer exists in text mode installs.

James had the suggestion of just removing the package selection UI from both text and graphical.  While that may be the right future direction, it's still a huge step for F11 so it's probably not going to happen.

It's my belief that we need to just halt if we get into this position.  A missing packages section cannot imply the default package set, as that's what %packages\n%end means.  I don't like overloading behavior like that.

However, I also understand that halting like that is not very friendly behavior, especially since partitioning will have already happened.  But we have a lot of power with pykickstart, so what if we do a check right after kickstart file processing that sees if the packages section is present or not?  If it's not, we can halt with an informative error message very early.

We can do this for any missing step that text mode no longer supports.
Comment 5 Chris Lumens 2009-02-04 15:50:37 EST
I've updated the notext.img file to provide the above check.  I think this is probably a reasonable thing to do regardless of how the packaging UI turns out.  We can always modify the list of steps we check for along the way.
Comment 6 Chris Lumens 2009-02-09 11:43:24 EST
I went with what's been outlined in comment #4.  This will be in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.