Bug 483127 - [RFE] Change User-swich-applet status text to icon instead.
[RFE] Change User-swich-applet status text to icon instead.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 14:32 EST by Jóhann B. Guðmundsson
Modified: 2015-01-14 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 01:05:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2009-01-29 14:32:30 EST
Description of problem:

Change user-switch-applet status text for example 
(Available) to an icon instead in the top gnome panel 

Ofcourse the icon would need to change as the user changes is status
from available busy and invisible.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2009-01-30 01:34:30 EST
We believe the text works better than an icon for this. 
Why do you think an icon would be better ?
Comment 2 Jóhann B. Guðmundsson 2009-01-30 06:35:14 EST
By having an icon instead of text you don't take away as much 
available icon space in the top bar and lower the risk of messing
up the top bar if the resolution and or fonts are changed. 
( I have had reports from people that if they hooked up their laptops to 
projector or tv, and they or the resolution has been change the top panel
goes fubar and seen some cases) 

Just image the mess if NM show if it was connected to a network or not.
(Wired Network Connected )

For example Lets use my full name. 
( Which could be taken from our cn field in our FDS )

Jóhann Benedikt Guðmundsson(Available)[$date$time][V]

Already this part takes ca 1 third of the top panel in current default resolution and font size.

I even go as far as say no text on the top panel except for 
[Application][Places][System]

The display named changed from a name to a icon set in the about me photo
or photo in ldap

The $date changed to 2 icons one mini calender and the other an old school circular clock icon or just digital format ( no text unless mouse is hovered over it to prevent any resolution and or fonts changes to mess up the top panel )
Comment 3 Matthias Clasen 2009-02-01 12:55:15 EST
> ( I have had reports from people that if they hooked up their laptops to 
> projector or tv, and they or the resolution has been change the top panel
> goes fubar and seen some cases) 

Thats a panel bug.

> Just image the mess if NM show if it was connected to a network or not.
> (Wired Network Connected )

That case is different, since we have well-established, easily readable icons for connection status. We don't have such icons for presence.
Comment 4 Jóhann B. Guðmundsson 2009-02-01 15:45:18 EST
"We don't have such icons for presence."

It sounds logically to me that this would use the same icons 
as the default IM client in Gnome uses and of course changes those icons if the icons to the default IM client are changed.

If that's not possible then asking the art team to come up with ones is not a bad idea.
Comment 5 Matthias Clasen 2009-02-02 22:51:50 EST
We don't have such icons for presence - not because nobody got around to drawing some, or because we didn't think of talking to the artists, but because it is next to impossible to represent abstract concepts such as 'busy' or 'available' in a 20x20 icon in a meaningful way. A green ball/square doesn't cut it...
Comment 6 jmccann 2009-02-05 14:46:20 EST
I've been talking to gnome-art about this for some time.  Lapo and jimmac worked on some ideas but as far as I know haven't finished them.

Note You need to log in before you can comment on or make changes to this bug.