This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 483165 - graphical install fails with ATI Technologies Inc M24 [FireMV 2400]
graphical install fails with ATI Technologies Inc M24 [FireMV 2400]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: OtherQA
Depends On:
Blocks: 510397
  Show dependency treegraph
 
Reported: 2009-01-29 17:27 EST by PaulB
Modified: 2009-09-02 07:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 510397 (view as bug list)
Environment:
Last Closed: 2009-09-02 07:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested: /etc/X11/xorg.conf (568 bytes, text/plain)
2009-02-04 14:45 EST, PaulB
no flags Details
Requested: /var/log/anaconda.xlog (26.28 KB, text/plain)
2009-02-04 14:46 EST, PaulB
no flags Details
Requested: /var/log/Xorg.0.log (26.21 KB, text/plain)
2009-02-04 14:49 EST, PaulB
no flags Details
/root/install.log (35.01 KB, text/plain)
2009-02-04 14:50 EST, PaulB
no flags Details
Xorg.0.log.radeon (26.20 KB, text/plain)
2009-04-24 17:15 EDT, PaulB
no flags Details
Xorg.0.log.r500 (68.01 KB, text/plain)
2009-04-24 17:15 EDT, PaulB
no flags Details
Xorg.0.log.r500April28 (68.06 KB, text/plain)
2009-04-28 16:00 EDT, PaulB
no flags Details

  None (edit)
Description PaulB 2009-01-29 17:27:34 EST
Description of problem:
graphical install fails with 
ATI Technologies Inc M24 [FireMV 2400]

Version-Release number of selected component (if applicable):
RHEL5u3 i386
RHEL5u3 x86_64

How reproducible:
everytime

Steps to Reproduce:
1. run the installer
2.
3.
  
Actual results:
graphical install fails.
Fails to startX

Expected results:
video card to be supported

Additional info:
If I append the boot line with the following
I am able to perform a graphical install:
xdriver=r500
or
xdriver=vesa


Here are some further details:
$kudzu -p -c VIDEO
-
class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc M24 [FireMV 2400] (Secondary)"
vendorId: 1002
deviceId: 3171
subVendorId: 1002
subDeviceId: 3150
pciType: 1
pcidom:    0
pcibus: a3
pcidev:  0
pcifn:  1
-
class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc M24 [FireMV 2400]"
video.xdriver: radeon
vendorId: 1002
deviceId: 3151
subVendorId: 1002
subDeviceId: 3151
pciType: 1
pcidom:    0
pcibus: a3
pcidev:  0
pcifn:  0
-
class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc M24 [FireMV 2400] (Secondary)"
vendorId: 1002
deviceId: 3171
subVendorId: 1002
subDeviceId: 3150
pciType: 1
pcidom:    0
pcibus: a2
pcidev:  0
pcifn:  1
-
class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc M24 [FireMV 2400]"
video.xdriver: radeon
vendorId: 1002
deviceId: 3151
subVendorId: 1002
subDeviceId: 3151
pciType: 1
pcidom:    0
pcibus: a2
pcidev:  0
pcifn:  0


Here are some even further details:
$lspci -d 1002:3151 -vv
a2:00.0 VGA compatible controller: ATI Technologies Inc M24 [FireMV 2400] (prog-if 00 [VGA controller])
	Subsystem: ATI Technologies Inc M24 [FireMV 2400]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 3
	Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at 2000 [size=256]
	Region 2: Memory at f0200000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at f0220000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [58] Express Endpoint IRQ 0
		Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
		Device: Latency L0s <256ns, L1 <4us
		Device: AtnBtn- AtnInd- PwrInd-
		Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
		Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
		Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
		Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s L1, Port 1
		Link: Latency L0s <256ns, L1 <2us
		Link: ASPM L0s L1 Enabled RCB 64 bytes CommClk- ExtSynch-
		Link: Speed 2.5Gb/s, Width x4
	Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
		Address: 0000000000000000  Data: 0000
	Capabilities: [100] Advanced Error Reporting

a3:00.0 Display controller: ATI Technologies Inc M24 [FireMV 2400]
	Subsystem: ATI Technologies Inc M24 [FireMV 2400]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 3
	Region 0: Memory at c0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at 1000 [size=256]
	Region 2: Memory at f0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at f0120000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [58] Express Endpoint IRQ 0
		Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
		Device: Latency L0s <256ns, L1 <4us
		Device: AtnBtn- AtnInd- PwrInd-
		Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
		Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
		Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
		Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s L1, Port 2
		Link: Latency L0s <256ns, L1 <2us
		Link: ASPM L0s L1 Enabled RCB 64 bytes CommClk- ExtSynch-
		Link: Speed 2.5Gb/s, Width x4
	Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
		Address: 0000000000000000  Data: 0000
	Capabilities: [100] Advanced Error Reporting
Comment 1 Matěj Cepl 2009-02-04 10:48:26 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/anaconda.xlog, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 PaulB 2009-02-04 14:45:39 EST
Created attachment 330906 [details]
Requested: /etc/X11/xorg.conf
Comment 3 PaulB 2009-02-04 14:46:24 EST
Created attachment 330907 [details]
Requested: /var/log/anaconda.xlog
Comment 4 PaulB 2009-02-04 14:49:11 EST
Created attachment 330908 [details]
Requested: /var/log/Xorg.0.log

Note:
As I did a text install, this file was populated via a  $startx  , after text install was completed.
Comment 5 PaulB 2009-02-04 14:50:00 EST
Created attachment 330909 [details]
/root/install.log
Comment 6 PaulB 2009-02-04 14:58:13 EST
Hello,
Regarding comments #2 , #3, #4, #5:

I reinstalled RHEL5u3 x86_64 without appending the boot line with:
xdriver=r500 or xdriver=vesa

Thus, I performed a text install to provide the above information.
After text installation completed, the  $startx  command was used to populate /var/log/Xorg.0.log

-PaulB
Comment 7 PaulB 2009-02-04 15:09:26 EST
Oops, I made a typo in comment #6!

I reinstalled RHEL5u3 x86_64 without appending the boot line "WITHOUT":
xdriver=r500 or xdriver=vesa


Sorry about that!  :)

-PaulB
Comment 9 RHEL Product and Program Management 2009-04-21 18:48:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 13 Dave Airlie 2009-04-23 23:33:26 EDT
MODIFIED

xorg-x11-drv-ati-6.6.3-3.24.el5

built in brew.
Comment 15 PaulB 2009-04-24 17:15:14 EDT
Created attachment 341249 [details]
Xorg.0.log.radeon
Comment 16 PaulB 2009-04-24 17:15:59 EDT
Created attachment 341250 [details]
Xorg.0.log.r500
Comment 17 Dave Airlie 2009-04-27 21:50:43 EDT
MODIFIED

xorg-x11-drv-ati-6.6.3-3.25.el5

built in brew.

I forgot to remove it from the original xinf after I added it to the r500 one.
Comment 19 PaulB 2009-04-28 16:00:37 EDT
Created attachment 341642 [details]
Xorg.0.log.r500April28
Comment 25 PaulB 2009-06-10 13:29:52 EDT
Dave,
The file X.log file is in ./tmp/ramfs.
I had to get a tip on its location from CMeaders.
I have attached the file, as X.log from RHEL5.4-Server-20090605.nightly.

Please let me know if I can assist further.

-PaulB
Comment 26 Adam Jackson 2009-06-11 13:59:02 EDT
This is an anaconda bug, stage2 generation is broken and doesn't include the dependencies of X drivers.  I suspect a variation on 0192eaadbfbe36fd950609563dc63c26f35da618 is needed.  Alternatively just add libdrm to PACKAGES and move on.
Comment 27 Chris Ward 2009-06-14 19:20:20 EDT
~~ Attention Partners RHEL 5.4 Partner Alpha Released! ~~

RHEL 5.4 Partner Alpha has been released on partners.redhat.com. There should
be a fix present that addresses this particular request. Please test and report back your results here, at your earliest convenience. Our Public Beta release is just around the corner!

If you encounter any issues, please set the bug back to the ASSIGNED state and
describe the issues you encountered. If you have verified the request functions as expected, please set your Partner ID in the Partner field above to indicate successful test results. Do not flip the bug status to VERIFIED. Further questions can be directed to your Red Hat Partner Manager. Thanks!
Comment 28 Chris Ward 2009-07-03 14:22:32 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 29 Dave Airlie 2009-07-08 22:31:15 EDT
assign back to -ati
Comment 30 Joel Andres Granados 2009-07-09 05:12:06 EDT
I'm going to include the libdrm package in the anaconda scripts.  This should be available in the next version of anaconda (11.1.2.186).
Comment 31 PaulB 2009-07-09 10:21:53 EDT
All,
Going to test but:
/RHEL5.4-Server-20090709.nightly
 has anaconda-11.1.2.185-1.x86_64.rpm.

Once the libdrm package is in the anaconda scripts:
Expected in the next version of anaconda (11.1.2.186), as stated by Joel. 
I will retest the installation and report results.

-PaulB
Comment 32 Chris Ward 2009-07-10 15:10:15 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 1 Released! ~~

RHEL 5.4 Snapshot 1 has been released on partners.redhat.com. If you have already reported your test results, you can safely ignore this request. Otherwise, please notice that there should be a fix available now that addresses this particular request. Please test and report back your results here, at your earliest convenience. The RHEL 5.4 exception freeze is quickly approaching.

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other appropriate customer representative.
Comment 33 Joel Andres Granados 2009-07-13 04:32:41 EDT
(In reply to comment #31)
> All,
> Going to test but:
> /RHEL5.4-Server-20090709.nightly
>  has anaconda-11.1.2.185-1.x86_64.rpm.
> 

Have not built anaconda yet, so the buggy behavior will probably not change.  I still need to know what files are needed for libdrm.  Since the installation image is size-constraint we choose each file that goes in.

FYI, I'm going to include the libdrm.so.* files from the package and build ASAP.
Comment 35 Adam Jackson 2009-07-13 17:58:04 EDT
This needs _all_ the DSOs in libdrm.  libdrm_radeon.so.* in particular, but, all of them.
Comment 38 Chris Ward 2009-08-03 11:46:07 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 5 Released! ~~

RHEL 5.4 Snapshot 5 is the FINAL snapshot to be release before RC. It has been 
released on partners.redhat.com. If you have already reported your test results, 
you can safely ignore this request. Otherwise, please notice that there should be 
a fix available now that addresses this particular issue. Please test and report 
back your results here, at your earliest convenience.

If you encounter any issues while testing Beta, please describe the 
issues you have encountered and set the bug into NEED_INFO. If you 
encounter new issues, please clone this bug to open a new issue and 
request it be reviewed for inclusion in RHEL 5.4 or a later update, if it 
is not of urgent severity. If it is urgent, escalate the issue to your partner manager as soon as possible. There is /very/ little time left to get additional code into 5.4 before GA.

Partners, after you have verified, do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other 
appropriate customer representative.
Comment 39 PaulB 2009-08-04 16:36:35 EDT
All,
I have posted this comment to the following BZs: bz#483165 and bz#510397

Installing w RHEL5.4-Server-20090804.nightly
(using the anaconda-11.1.2.194-1.x86_64.rpm)

The graphical install is now successful!

-PaulB
Comment 41 errata-xmlrpc 2009-09-02 07:12:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1343.html

Note You need to log in before you can comment on or make changes to this bug.