Bug 483170 - Radeon XPRESS 200M (RC410) - enabling and disabling compiz repeatedly eventually crashes xserver
Radeon XPRESS 200M (RC410) - enabling and disabling compiz repeatedly eventua...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
card_RC410
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 18:00 EST by Alex Villacís Lasso
Modified: 2009-10-23 03:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-23 03:38:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of session where xorg crashed (29.79 KB, text/plain)
2009-01-29 18:00 EST, Alex Villacís Lasso
no flags Details
xserver log of crashed session (138.60 KB, text/plain)
2009-01-29 18:02 EST, Alex Villacís Lasso
no flags Details
Output of lspci -v (5.09 KB, text/plain)
2009-01-29 18:03 EST, Alex Villacís Lasso
no flags Details
xorg.conf used with xserver (1.75 KB, text/plain)
2009-01-29 18:05 EST, Alex Villacís Lasso
no flags Details
My Xorg.0.log from the crash. (78.58 KB, text/plain)
2009-02-24 16:03 EST, Samuel Sieb
no flags Details

  None (edit)
Description Alex Villacís Lasso 2009-01-29 18:00:56 EST
Created attachment 330414 [details]
dmesg output of session where xorg crashed

Description of problem:

On this machine, I installed Fedora 10 and updated it to the latest packages. Then I installed compiz-fusion in order to enable desktop effects. I kept switching between compiz and metacity in GNOME. Eventually, after two or three switches back and forth, the X server crashes on me and I am returned to the graphical login. Using ati driver from updates-testing does not help.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.5.3-6.fc10.i386
xorg-x11-drv-ati-6.10.0-1.fc10.i386
mesa-libGL-7.2-0.15.fc10.i386
mesa-dri-drivers-7.2-0.15.fc10.i386
kernel-2.6.27.12-170.2.5.fc10.i686

How reproducible:
Always.

Steps to Reproduce:
1. Get a Radeon RC410 chipset to test
2. In GNOME, install compiz-fusion and switch back and forth between metacity and compiz.
3. Repeat until crash
  
Actual results:
xserver crashes

Expected results:
no xserver crash

Additional info:
Comment 1 Alex Villacís Lasso 2009-01-29 18:02:18 EST
Created attachment 330415 [details]
xserver log of crashed session
Comment 2 Alex Villacís Lasso 2009-01-29 18:03:15 EST
Created attachment 330416 [details]
Output of lspci -v
Comment 3 Alex Villacís Lasso 2009-01-29 18:05:06 EST
Created attachment 330417 [details]
xorg.conf used with xserver
Comment 4 Samuel Sieb 2009-02-24 16:02:45 EST
I get this on a laptop with an X300:
kernel-2.6.27.15-170.2.24.fc10.i686
xorg-x11-drv-ati-6.10.0-2.fc10.i386

No xorg.conf.

Enable desktop effects, disable desktop effects, enable desktop effect, crash.

Program received signal SIGSEGV, Segmentation fault.
0x0055dd7f in dri_bo_reference (bo=0x9abeef8) at radeon_dri_bufmgr.c:58
58	   bo->bufmgr->bo_reference(bo);
(gdb) where
#0  0x0055dd7f in dri_bo_reference (bo=0x9abeef8) at radeon_dri_bufmgr.c:58
#1  0x0053b59b in bufmgr_classic_emit_reloc (batch_buf=0x99d3808, 
    flags=16777216, delta=0, offset=732, target=0x9abeef8) at r300_mem.c:792
#2  0x0055de43 in dri_emit_reloc (reloc_buf=0x99d3808, flags=16777216, 
    delta=0, offset=732, target_buf=0x9abeef8) at radeon_dri_bufmgr.c:137
#3  0x005425e1 in emit_cb_offset (r300=0x9eb1410) at r300_cmdbuf.c:356
#4  0x0054291c in r300EmitAtoms (r300=0x9eb1410, dirty=1 '\001')
    at r300_cmdbuf.c:247
#5  0x00542078 in r300EmitState (r300=0x9eb1410) at r300_cmdbuf.c:297
#6  0x0054214e in r300BeginBatch (r300=0x9eb1410, n=4, autostate=1 '\001', 
    function=0x56a774 "r300EmitCacheFlush", line=487) at r300_cmdbuf.c:192
#7  0x00556de4 in r300EmitCacheFlush (rmesa=0x9eb1410) at r300_emit.c:487
#8  0x00548286 in r300RunRender (ctx=0x9eda0e8, stage=<value optimized out>)
    at r300_render.c:316
#9  0x010bd059 in _tnl_run_pipeline (ctx=0x9eda0e8) at tnl/t_pipeline.c:158
#10 0x010bdaa4 in _tnl_draw_prims (ctx=0x9eda0e8, arrays=0x9ca2b20, 
    prim=0xbfe587b0, nr_prims=1, ib=0x0, min_index=0, max_index=15)
    at tnl/t_draw.c:402
#11 0x010b57ce in vbo_exec_DrawArrays (mode=7, start=0, count=16)
    at vbo/vbo_exec_array.c:267
#12 0x010a678b in neutral_DrawArrays (mode=7, start=0, count=16)
    at main/vtxfmt_tmp.h:328
#13 0x0017434d in __glXDisp_DrawArrays (pc=0x9aa85c4 "") at render2.c:248
#14 0x0016ddaf in __glXDisp_Render (cl=0x9a6e934, pc=0x9aa8594 "h\001�")
    at glxcmds.c:1789
#15 0x0017263a in __glXDispatch (client=0x9a6e748) at glxext.c:512
#16 0x08085e9f in Dispatch () at dispatch.c:454
#17 0x0806b71d in main (argc=8, argv=0xbfe58a14, envp=Cannot access memory at address 0x291
) at main.c:441
Comment 5 Samuel Sieb 2009-02-24 16:03:34 EST
Created attachment 333088 [details]
My Xorg.0.log from the crash.
Comment 6 Yul Rottmann 2009-05-02 08:49:18 EDT
I get this on my X700Pro PCIe. Even if I log in and then the desktop effects are enabled it sometimes crashes and the screen goes black and then again to the gdm log in. After a few tries it works sometimes, but sometimes it freezes completely. Glxgears work fine when having desktop effects, but other 3d application cause the crash. :(
Comment 7 Jérôme Glisse 2009-10-14 07:26:53 EDT
Can you test with fedora 12 livecd and report if it works with it.
Comment 8 Yul Rottmann 2009-10-22 13:58:03 EDT
At least I cannot reproduce this bug any more. Thanks.
Comment 9 Jérôme Glisse 2009-10-23 03:38:05 EDT
So i am closing it, reopen if it happens again with newer version of fedora.

Note You need to log in before you can comment on or make changes to this bug.