Bug 483197 - [hi_IN] Download window not showing any information
[hi_IN] Download window not showing any information
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 01:50 EST by A S Alam
Modified: 2013-07-02 20:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: firefox-3.0.12-1.el5_3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 04:18:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firefox Download Window (39.11 KB, image/png)
2009-01-30 01:50 EST, A S Alam
no flags Details
Fixed Screenshot in Hindi (20.82 KB, image/png)
2010-05-27 23:52 EDT, A S Alam
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 480292 None None None Never

  None (edit)
Description A S Alam 2009-01-30 01:50:15 EST
Created attachment 330440 [details]
Firefox Download Window 

Description of problem:
While using firefox  for download anything in Hindi (hi_IN) language, it was not showing any information regarding download

Version-Release number of selected component (if applicable):
firefox-3.0.6-1.el5

How reproducible:
90%

Steps to Reproduce:
1. run firefox in Hindi (hi_IN.UTF-8) locale
2. start any bid download
3. there is download windows
  
Actual results:
Nothing is shown in download window

Expected results:
information regarding Download should be there.

Additional info:
1) Status bar was showing that something is under progress (downloading...),
but Download window - Nothing was there

2) Screenshot attached
3) gu_IN, ta_IN working fine (showing Download)
Comment 1 A S Alam 2009-01-30 01:52:02 EST
sorry forgot to add eng-i18n-list
Comment 2 A S Alam 2009-01-30 02:06:26 EST
just FYI:
during investigation, I found error in translation. There is file name downloads.dtd in hi-IN.jar
(in /usr/lib/firefox-3.0.6/extensions/langpack-hi-IN@firefox.mozilla.org/chrome/)

hi-IN.jar -> (unzip) -> locale/hi-IN/mozapps/downloads/downloads.dtd


There is space after Entity
<$ENTITY window.height "300"> 

that make issue.

If removed, it works fine.
Comment 4 RHEL Product and Program Management 2009-02-26 04:27:15 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 6 A S Alam 2009-02-26 05:47:55 EST
oh, but it is working in upstream version: 3.0.0.6, seems only problem with RHEL version. Only Our version has some problem
Comment 8 Jens Petersen 2010-04-14 00:58:42 EDT
So Hindi langpack needs updating?
Comment 9 A S Alam 2010-04-14 01:03:47 EDT
yes, it is translation issue (comment #2)
added eng-l10n team
Comment 10 Martin Stransky 2010-04-14 02:21:02 EDT
Please check an updated firefox package for rhel-5.5.z - Bug 509156
Comment 11 Ankit Patel 2010-04-14 03:01:10 EDT
(In reply to comment #9)
> yes, it is translation issue (comment #2)
> added eng-l10n team    

If extra space at the end of the line is an issue than Firefox shouldn't be working properly for Gujarati (gu-IN) even, as Gujarati file also do have an extra space at the end of the line, where entity for 'height' is mentioned. Btw, there are number of files in entire firefox translations where there are extra spaces end of the line for entities, so this shouldn't be a fix I guess.

Anyways, Firefox is going to be rebased to 3.6, looks like all acks are + for bug 509156, so let's know if we are still supposed to fix this bug.

Thanks!
Ankit
Comment 12 Martin Stransky 2010-04-14 03:15:54 EDT
We need to check if the bug affects the new 3.6 package and eventually fix it there.
Comment 13 Ankit Patel 2010-04-14 03:29:40 EDT
(In reply to comment #12)
> We need to check if the bug affects the new 3.6 package and eventually fix it
> there.    

QE team could intimate us in case of regression.
Comment 14 A S Alam 2010-05-27 23:52:53 EDT
Created attachment 417458 [details]
Fixed Screenshot in Hindi

Tested with following version:
firefox-3.0.12-1.el5_3
it is FIXED
not closing as need to confirm with 3.6 Firefox and then close.
Comment 15 Jens Petersen 2010-08-03 04:18:18 EDT
I tested firefox 3.6 is fine too in el6.

Note You need to log in before you can comment on or make changes to this bug.