Bug 483225 - Segmentation fault when running gnome-default-applications-properties
Segmentation fault when running gnome-default-applications-properties
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
: 485680 486861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 05:58 EST by David Nielsen
Modified: 2009-03-16 15:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.24.0.1-13.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 15:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of problem (8.95 KB, text/plain)
2009-01-30 05:59 EST, David Nielsen
no flags Details
gdb backtrace of segfault (2.85 KB, text/plain)
2009-03-15 12:42 EDT, cruiseoveride
no flags Details

  None (edit)
Description David Nielsen 2009-01-30 05:58:30 EST
Description of problem:
I get a segmentation fault everytime I run gnome-default-applications-properties, attached is a backtrace of the problem.

Version-Release number of selected component (if applicable):
control-center-2.24.0.1-12.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run gnome-default-applications-properties
  
Actual results:
Segfault

Expected results:
successful execution

Additional info:
x86_64, da_DK.UTF-8
Comment 1 David Nielsen 2009-01-30 05:59:44 EST
Created attachment 330455 [details]
backtrace of problem
Comment 2 Bastien Nocera 2009-01-30 06:30:46 EST
My guess is that "item" is NULL.

Could you try to print "item" in gdb, as well as item->generic, item->tab_command and item->win_command if item isn't NULL?

What's the output of "gconftool-2 -R  /desktop/gnome/url-handlers/http" on your system?
Comment 3 David Nielsen 2009-01-30 06:35:05 EST
ah I found the problem, all relevant URL handlers were set to firefox %s but epiphany is the only browser installed. Still one could imagine a more graceful handling than segfaulting but now it works at least.
Comment 4 Bastien Nocera 2009-01-30 07:41:07 EST
Could you please reset your setup to what it was and check whether this build fixes it?
http://koji.fedoraproject.org/koji/taskinfo?taskID=1093592
Comment 5 David Nielsen 2009-01-31 06:41:53 EST
Using the above packages on a resat configuration does indeed fix the problem. Thank you.
Comment 6 Bastien Nocera 2009-02-16 09:14:31 EST
*** Bug 485680 has been marked as a duplicate of this bug. ***
Comment 7 Joachim Frieben 2009-02-22 14:11:46 EST
I can confirm that control-center-2.24.0.1-13.fc10.x86_64 from updates-testing does indeed fix the issue [btw, even without having reset the user configuration]. Pushing to updates?
Comment 8 Jan Horak 2009-02-24 10:23:21 EST
*** Bug 486861 has been marked as a duplicate of this bug. ***
Comment 9 cruiseoveride 2009-03-15 12:42:21 EDT
Created attachment 335260 [details]
gdb backtrace of segfault

I can confirm the bug. FC10 X86_64

Attempting to select the "Custom" option in the Web Browser selection list, causes gnome-default-applications-properties to segfault. See attachment for bt.
Comment 10 Joachim Frieben 2009-03-15 13:53:05 EDT
Can an entitled person push control-center-2.24.0.1-13.fc10 to updates, please? It fixed the issue already back in January? Thank you!
Comment 11 Fedora Update System 2009-03-16 15:44:16 EDT
control-center-2.24.0.1-13.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.