Bug 483322 - alsa-plugins : Unowned directories
alsa-plugins : Unowned directories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-plugins (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Moret
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 15:31 EST by Michael Schwendt
Modified: 2009-08-14 19:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 19:38:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-01-30 15:31:52 EST
One or more directories are not included within this
package and/or its sub-packages:

=> alsa-plugins-1.0.18-2.fc11.src.rpm
=> alsa-plugins-oss-1.0.18-2.fc11.i386 (rawhide-development-i386)
/etc/alsa  [ provided by: alsa-utils-1.0.19-1.fc11.i386 ]
/etc/alsa/pcm

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n alsa-plugins
Comment 1 Michael Schwendt 2009-01-30 15:33:44 EST
=> alsa-plugins-1.0.18-2.fc11.src.rpm
=> alsa-plugins-jack-1.0.18-2.fc11.i386 (rawhide-development-i386)
/etc/alsa  [ provided by: alsa-utils-1.0.19-1.fc11.i386 ]
/etc/alsa/pcm

=> alsa-plugins-1.0.18-2.fc11.src.rpm
=> alsa-plugins-oss-1.0.18-2.fc11.i386 (rawhide-development-i386)
/etc/alsa  [ provided by: alsa-utils-1.0.19-1.fc11.i386 ]
/etc/alsa/pcm

=> alsa-plugins-1.0.18-2.fc11.src.rpm
=> alsa-plugins-pulseaudio-1.0.18-2.fc11.i386 (rawhide-development-i386)
/etc/alsa  [ provided by: alsa-utils-1.0.19-1.fc11.i386 ]

=> alsa-plugins-1.0.18-2.fc11.src.rpm
=> alsa-plugins-samplerate-1.0.18-2.fc11.i386 (rawhide-development-i386)
/etc/alsa  [ provided by: alsa-utils-1.0.19-1.fc11.i386 ]
/etc/alsa/pcm

=> alsa-plugins-1.0.18-2.fc11.src.rpm
=> alsa-plugins-upmix-1.0.18-2.fc11.i386 (rawhide-development-i386)
/etc/alsa  [ provided by: alsa-utils-1.0.19-1.fc11.i386 ]
/etc/alsa/pcm

=> alsa-plugins-1.0.18-2.fc11.src.rpm
=> alsa-plugins-vdownmix-1.0.18-2.fc11.i386 (rawhide-development-i386)
/etc/alsa  [ provided by: alsa-utils-1.0.19-1.fc11.i386 ]
/etc/alsa/pcm
Comment 2 Eric Moret 2009-04-25 03:34:14 EDT
I have made the required changes in rawhide. Since we are in the f11 freeze period, this should will be seen in f12.
Comment 3 Bug Zapper 2009-06-09 06:59:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.