Bug 483383 - nufw : Unowned directories
nufw : Unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nufw (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jerome Soyer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-31 06:44 EST by Michael Schwendt
Modified: 2009-04-01 05:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 05:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-01-31 06:44:25 EST
One or more directories are not included within this
package and/or its sub-packages:

=> nufw-2.2.20-7.fc11.src.rpm
=> nuauth-2.2.20-7.fc11.i386 (rawhide-development-i386)
/usr/lib/nuauth
/usr/lib/nuauth/modules

=> nufw-2.2.20-7.fc11.src.rpm
=> nuauth-auth-ldap-2.2.20-7.fc11.i386 (rawhide-development-i386)
/usr/lib/nuauth
/usr/lib/nuauth/modules

=> nufw-2.2.20-7.fc11.src.rpm
=> nuauth-log-mysql-2.2.20-7.fc11.i386 (rawhide-development-i386)
/usr/lib/nuauth
/usr/lib/nuauth/modules

=> nufw-2.2.20-7.fc11.src.rpm
=> nuauth-log-pgsql-2.2.20-7.fc11.i386 (rawhide-development-i386)
/usr/lib/nuauth
/usr/lib/nuauth/modules

=> nufw-2.2.20-7.fc11.src.rpm
=> nuauth-log-prelude-2.2.20-7.fc11.i386 (rawhide-development-i386)
/usr/lib/nuauth
/usr/lib/nuauth/modules

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n ^nuauth
Comment 1 Jerome Soyer 2009-01-31 11:16:26 EST
I fix this in 2.2.20-8 :-)

http://koji.fedoraproject.org/koji/buildinfo?buildID=81034
Comment 2 Michael Schwendt 2009-01-31 12:05:53 EST
The fix is insufficient, because "nuauth" doesn't own those directories either.
Comment 3 Michael Schwendt 2009-04-01 05:52:49 EDT
Fix committed, build requested.
Tagged with: nufw-2_2_21-3_fc11

Note You need to log in before you can comment on or make changes to this bug.