Bug 483394 - RFE: Switch to 1.6 for F11
RFE: Switch to 1.6 for F11
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wesnoth (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
: 491770 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-31 11:31 EST by Bruno Wolff III
Modified: 2009-03-24 10:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 10:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-01-31 11:31:55 EST
Description of problem:
I am not sure if you follow the dev list. But in case you don't, they are intending to release 1.5.9 tomorrow and advertise it as the first 1.6 beta.
In my opinion it seems like a good time to switch over to the 1.6 version in Fedora.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Warren Togami 2009-01-31 13:07:27 EST
What is their estimated release schedule for 1.6?  We don't want to be caught releasing F11 before 1.6 is out.
Comment 2 Bruno Wolff III 2009-01-31 14:03:48 EST
The message that prompted my RFE can be found at:
https://mail.gna.org/public/wesnoth-dev/2009-01/msg00094.html
Based on that message, I think even with significant slippage the 1.6 branch should be fine by the F11 release. They are pretty much moving into a bug fix mode now, so that tracking the 1.5/1.6 version from now to the release shouldn't cause additional problems over the one time switch away from 1.4.
Comment 3 Bruno Wolff III 2009-01-31 14:15:02 EST
Some IRC feedback included a comment that 1.5 is a bit buggy right now and that getting the number of those down to an acceptable level in the next 3 weeks will be difficult. So expect an early March release to be overly optimistic.
You can look at the irc comments at:
http://wesnoth.debian.net/%23wesnoth-dev-2009-01-31.log
Shortly after I (brunowolff) asked about an official time line. In particular read ESR's comment.
Comment 4 Bruno Wolff III 2009-01-31 14:31:44 EST
A couple of pages you can watch on their wiki for updates:
Feature and critical bug status:
http://www.wesnoth.org/wiki/Wesnoth1.6Features
A timeline that is currently a bit out of date:
http://www.wesnoth.org/wiki/Wesnoth1.6ReleasePlan
Comment 5 Gwyn Ciesla 2009-02-02 11:39:27 EST
Thanks for the footwork, Bruno.  That's good information.

Looking at the irc log and the feature and release pages, my gut is to start playing with builds, but not put anything in rawhide until much closer to Beta.  I'm really hoping to get 1.6 in F11, because you *know* users will clamor for it the second it's out, but from the way it sounds on irc combined with the lack of updates to the schedule make me hesitant to bother putting it in rawhide now.  

I agree that we should really try for Beta as a cutoff, but I could see putting it in afterward if it's not too far after Beta(3/24), but really not later than the Software Translation Deadline(4/7).

Then again, Warren, if you can make a compelling case the other way, I'm certainly more than willing to consider that.  I'd say the bulk of users I've run into would favor bleeding-edgeness over caution. :)
Comment 6 Bruno Wolff III 2009-02-02 13:26:53 EST
I like that plan. That gives you a way to see if there are any problems early.
There is a new editor and they are depreciating autotools, though I don't know if they have made a definitive decision between cmake and scons. I have seen scons changes recently, but don't remember seeing any cmake ones. (Though I just skim the commit messages and could easily have missed some.) Auto tools is still working fine in F10 for builds. When gcc 4.4 goes in to rawhide, I'll test to see that things still work in F11. I am not a very active Wesnoth developer currently, but can commit simple fixes if I run accross something easy to fix.
I haven't been watching the test multiplayer servers recently, but in the past the development branch servers tended to get significant use. But Wesnoth was a lot newer then. Still I would expect to see very fast change over at the release.
If you really want to get ambitious you could also have parallel branches. The preference location became configurable as part of the build process at some point (I think during 1.3) and you can have two copies installed at the same time and switch between without messing things up.
Comment 7 Gwyn Ciesla 2009-02-04 13:19:01 EST
FYI 1.5.9 is out, and I'm playing with local builds now.
Comment 8 Bruno Wolff III 2009-02-21 10:07:47 EST
In https://mail.gna.org/public/wesnoth-dev/2009-02/msg00014.html an updated release plan is included. The release plan web page was also updated. The release (tagging) is currently being targeted for March 15.
Comment 9 Bruno Wolff III 2009-02-21 10:12:13 EST
Related to this I having been seening gcc 4.4 warnings while building Wesnoth. So far two were bugs in gcc that have been corrected. I had the default setting that promotes warnings to errors on so I don't know the full scope. There is a third group of warnings I am asking about on the Wesnoth dev list before filing another gcc bug. So far all of the warnings have been aliasing related.
I am going to build without the warning promotion since I need to test a feature they are considering dropping (gamma adjustment) and I need a working version.
Comment 10 Bruno Wolff III 2009-02-22 00:23:21 EST
In this followup (https://mail.gna.org/public/wesnoth-dev/2009-02/msg00019.html) ESR expresses optimism that the updated schedule is realistic.
Comment 11 Bruno Wolff III 2009-02-22 15:25:33 EST
Another FYI.
A discussion (https://mail.gna.org/public/wesnoth-dev/2009-02/msg00021.html) about build systems started today. It looks like autotools will be usable for 1.6 and a switch won't happen (assuming a decision gets made) until 1.7.
Comment 12 Gwyn Ciesla 2009-03-04 13:33:06 EST
Doing a local test build of 1.5.12, will be in rawhide today or tomorrow.
Comment 13 Gwyn Ciesla 2009-03-11 10:52:40 EDT
Doing a local test build of 1.5.13, will be in rawhide today or tomorrow.
Comment 14 Bruno Wolff III 2009-03-17 10:52:50 EDT
A call went out for final changes before 1.6. They need to be on the 18th and the release is expected this Sunday.
Comment 15 Gwyn Ciesla 2009-03-17 10:57:37 EDT
1.5.14 is in rawhide.
Comment 16 Bruno Wolff III 2009-03-17 11:09:59 EDT
ESR has replied with a counter proposal to wait another week to get some AI improvements in that are pretty close to ready. So it may end up being one more week. But it does look like the next release will be 1.6.
Comment 17 Gwyn Ciesla 2009-03-23 11:02:11 EDT
1.6 testing in progress, will hit rawhide today or tomorrow.
Comment 18 Gwyn Ciesla 2009-03-24 08:23:32 EDT
*** Bug 491770 has been marked as a duplicate of this bug. ***
Comment 19 Gwyn Ciesla 2009-03-24 10:23:30 EDT
1.6 is in rawhide.  Entertainment RelNotes Beat updated.

Note You need to log in before you can comment on or make changes to this bug.