Bug 483502 - asymptote gets ambiguous function calls from pstoedit
asymptote gets ambiguous function calls from pstoedit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: asymptote (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 17:20 EST by Michal Jaegermann
Modified: 2009-02-18 13:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 13:48:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-02-01 17:20:24 EST
Description of problem:

As a results of experiments with a facility described in "PostScript to Asymptote" chapter of asymptote manual, and using venn.eps example as described there, I was getting an asymptote code which, when fed back to asymptote, generated complaints like that:

test.asy: 27.10: call of function 'beginclip(guide)' is ambiguous

Only after appending ', false, currentpen, true' to call arguments to get a signature of a function defined in runtime.cc from asymptote sources that code was accepted without any complaints.  (BTW - the second pair of beginclip .. endclip is not really needed in that example).

A simpler way out appear to be to comment out beginclip and endclip definitions in /usr/share/asymptote/pstoedit.asy.  With that everything worked as expected when I tried without any changes in a pstoedit generated code.  Just dropping the whole 'import pstoedit;' is not an option as this causes "cannot call 'void gsave(frame f)' without parameters" complaints.

Version-Release number of selected component (if applicable):
asymptote-1.60-1.fc11

How reproducible:
as described above

Additional info:
It did not matter if I patched or not pstoedit following "PostScript to Asymptote" chapter of asymptote manual.  Actually results looked the same before and after but maybe differences will show up in some other examples?
Comment 1 Tom "spot" Callaway 2009-02-18 13:48:03 EST
This is fixed in 1.63-4 (in rawhide).

Note You need to log in before you can comment on or make changes to this bug.