Bug 483511 - GDM restarts when trying to login with a bluetooth mouse connected.
GDM restarts when trying to login with a bluetooth mouse connected.
Status: CLOSED DUPLICATE of bug 472965
Product: Fedora
Classification: Fedora
Component: thinkfinger (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 19:49 EST by Leonidas Georgopoulos
Modified: 2009-02-08 13:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 12:18:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (53.82 KB, text/plain)
2009-02-01 21:41 EST, Leonidas Georgopoulos
no flags Details
portion of /var/log/messages (10.49 KB, text/plain)
2009-02-01 21:43 EST, Leonidas Georgopoulos
no flags Details

  None (edit)
Description Leonidas Georgopoulos 2009-02-01 19:49:27 EST
Description of problem:
The following combination does not work:
fingerprint reader + bluetooth mouse


Version-Release number of selected component (if applicable):
uname -r --> 2.6.27.12-170.2.5.fc10.i686
thinkfigner --> thinkfinger-0.3-8.fc9.i386
bluez -->
bluez-gnome-analyzer-1.8-11.fc10.i386
bluez-gnome-1.8-11.fc10.i386
bluez-cups-4.22-2.fc10.i386
bluez-alsa-4.22-2.fc10.i386
pybluez-0.15-2.fc10.i386
bluez-4.22-2.fc10.i386
bluez-gstreamer-4.22-2.fc10.i386
bluez-hcidump-1.42-2.fc10.i386
bluez-libs-4.22-2.fc10.i386

consolekit --> 
ConsoleKit-x11-0.3.0-2.fc10.i386
ConsoleKit-0.3.0-2.fc10.i386
ConsoleKit-libs-0.3.0-2.fc10.i386

pam -->
pam_smb-1.1.7-9.fc10.i386
pam_ccreds-7-3.fc10.i386
pam_fprint-0.2-3.fc9.i386
pam-devel-1.0.2-2.fc10.i386
pam_krb5-2.3.2-1.fc10.i386
gnome-keyring-pam-2.24.1-1.fc10.i386
pam-1.0.2-2.fc10.i386
pam_passwdqc-1.0.5-1.i386

How reproducible:
Everytime

Steps to Reproduce:
1. Connect a bluetooth mouse (if trusted already, just move the mouse to get connected)
2. open a gnome-terminal or switch CTRL+ALT+F2/F3...
3. login / or execute su - (user)
  
Actual results:
Once the username is entered and before you enter the password the gdm is restarted.

Expected results:
Password prompt with swipe finger enabled.


Additional info:
If the mouse is not connected this works normally. e.g. with a bluetooth keyboard connected.

...will update soon with message log.
Comment 1 Leonidas Georgopoulos 2009-02-01 21:28:49 EST
It happened also with a bluetooth keyboard connected (but it is rare)

Here is the portion of /var/log/messages with the relative message:

Feb  2 03:06:57 localhost bluetoothd[2935]: link_key_request (sba=00:1C:26:FE:18:10, 
dba=00:07:61:84:69:BD)
Feb  2 03:06:58 localhost kernel: input: Logitech diNovo Keyboard as /devices/pci0000
:00/0000:00:1a.0/usb3/3-1/3-1:1.0/bluetooth/hci0/hci0:11/input20
Feb  2 03:18:11 localhost kernel: input: Virtual ThinkFinger Keyboard as /devices/vir
tual/input/input21
Comment 2 Leonidas Georgopoulos 2009-02-01 21:41:36 EST
Created attachment 330576 [details]
dmesg output
Comment 3 Leonidas Georgopoulos 2009-02-01 21:43:46 EST
Created attachment 330577 [details]
portion of /var/log/messages 

Tested from scratch. steps:

1. /etc/init.d/bluetooth restart
2. connect the mouse and pair
3. open terminal
4. su -
Comment 4 Leonidas Georgopoulos 2009-02-08 12:18:48 EST

*** This bug has been marked as a duplicate of bug 472965 ***
Comment 5 Leonidas Georgopoulos 2009-02-08 13:57:49 EST
Workaround:

install libfprint and pam_fprint

edit system-auth and replace line
auth        sufficient    pam_thinkfinger.so 


with

auth        sufficient    pam_fprint.so 

in

/etc/pam.d/system-auth


This will switch from the thinkfinger module that creates a new uinput every time to another one. This will overcome the problem of crashing haldaemon after 20+ virtual inputs.

Note You need to log in before you can comment on or make changes to this bug.