Bug 483571 - Anaconda needs to remove unsupported characters from hostname before using as VG name
Anaconda needs to remove unsupported characters from hostname before using as...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:3207a2d1248259daf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 09:33 EST by James Laska
Modified: 2013-09-02 02:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (115.10 KB, text/plain)
2009-02-02 09:33 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-02-02 09:33:22 EST
This bug was filed automatically by anaconda.
Comment 1 James Laska 2009-02-02 09:33:25 EST
Created attachment 330627 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-02-05 10:41:02 EST
This fails because the hostname on this system contains a dash '-' which is then used by anaconda in the LVM Volume Group name

anaconda 11.5.0.12 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/lvm.py", line 282, in vgremove
    raise VGRemoveError, vgname
  File "/usr/lib/anaconda/partitions.py", line 1787, in doMetaDeletes
    lvm.vgremove(delete.name)
  File "/usr/lib/anaconda/packages.py", line 136, in turnOnFilesystems
    anaconda.id.partitions.doMetaDeletes(anaconda.id.diskset)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1358, in nextClicked
    self.anaconda.dispatch.gotoNext()
VGRemoveError: vgremove of vg "vg_hp-xw930000" failed
Log:
   Using volume group(s) on command line
   Finding volume group "vg_hp-xw930000"
   Wiping cache of LVM-capable devices
   Couldn't find device with uuid 'zyMBEG-Igky-GR11-1814-x0dk-8GdF-E9GwGF'.
   Couldn't find device with uuid '9eE902-xPPq-HMtH-Dslq-kvxN-4Z5p-imG3lp'.
   There are 2 physical volumes missing.
   Volume group "vg_hp-xw930000" not found, is inconsistent or has PVs missing.
   Consider vgreduce --removemissing if metadata is inconsistent.
Comment 3 Chris Lumens 2009-02-05 13:47:53 EST
This should be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.