Bug 483574 - yum updates fail with strange dbus related error message
yum updates fail with strange dbus related error message
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 09:51 EST by Jes Sorensen
Modified: 2014-01-21 18:07 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 15:41:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2009-02-02 09:51:14 EST
Description of problem:
On one of our Fedora 10 systems I see this error message when trying to update packages with yum. This is after a reboot so I don't believe there is a problem with dbus being stale, and I also ran yum-complete-transactions and still see the problem.

The below is from updating yum, but other packages fail similarly after the yum update as well.

The main issue is that the GUI package update tool fails because of this.

[root@stupsi ~]# yum install yum
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package yum.noarch 0:3.2.20-5.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch             Version                 Repository         Size
================================================================================
Updating:
 yum           noarch           3.2.20-5.fc10           updates           839 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 839 k
Is this ok [y/N]: y
Downloading Packages:
yum-3.2.20-5.fc10.noarch.rpm                             | 839 kB     00:03     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : yum                                                      1/2 
  Cleanup        : yum                                                      2/2 
ERROR:dbus.proxies:Introspect error on :1.44:/org/freedesktop/PackageKit: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)" destination ":1.44")

Updated:
  yum.noarch 0:3.2.20-5.fc10                                                    

Complete!
[root@stupsi ~]# yum install 




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 seth vidal 2009-02-02 09:55:20 EST
reassigning to packagekit as it looks like it is coming out of that plugin.
Comment 2 Richard Hughes 2009-02-02 10:45:55 EST
What version dbus and PackageKit? What's the last 20 lines of /var/log/PackageKit say? Thanks.
Comment 3 Jes Sorensen 2009-02-02 11:02:39 EST
[root@stupsi ~]# rpm -q dbus PackageKit
dbus-1.2.6-1.fc10.x86_64
PackageKit-0.3.9-4.fc10.x86_64

Doesn't look like there is any /var/log/PackageKit file:

[root@stupsi ~]# find /var/log/ -name \*Package\*
[root@stupsi ~]# 

This system has been updated from Fedora 7 through 8 then 10, if I remember correctly ....
Comment 4 Jes Sorensen 2009-02-11 11:49:40 EST
Richard,

Is this information sufficient or do you need more info?

Thanks,
Jes
Comment 5 Richard Hughes 2009-02-16 10:57:47 EST
Do you still get this with all the latest updates installed?
Comment 6 Jes Sorensen 2009-02-18 11:51:55 EST
I updated yum, Package-Kit, rpm and I no longer see the error message.

Think it should be ok to close this bugzilla.

Thanks,
Jes

Note You need to log in before you can comment on or make changes to this bug.