Bug 483597 - [RHEL5.3][device mapper] list-hardrives does not return mapper devices
[RHEL5.3][device mapper] list-hardrives does not return mapper devices
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Joel Andres Granados
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 10:44 EST by Jeff Burke
Modified: 2009-05-08 10:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 10:46:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg file (2.89 KB, text/plain)
2009-02-02 10:45 EST, Jeff Burke
no flags Details
anaconda.log (21.07 KB, text/plain)
2009-02-02 10:46 EST, Jeff Burke
no flags Details
syslog (21.49 KB, text/plain)
2009-02-02 10:46 EST, Jeff Burke
no flags Details
script to list disks (2.46 KB, patch)
2009-04-21 08:47 EDT, Joel Andres Granados
no flags Details | Diff

  None (edit)
Description Jeff Burke 2009-02-02 10:44:23 EST
Description of problem:
 RHEL5.3 fails to install when kickstart is tries to partition a system with mapper devices.

Version-Release number of selected component (if applicable):
 RHEL5.3

How reproducible:
 Always

Steps to Reproduce:
1. Try to install on a system that will use mapper devices.
2. Run list-hardrives
  
Actual results:
# list-harddrives
  sda 76316.5942383

# cat /proc/partitions
major minor  #blocks  name
   7     0      88956 loop0
   8     0   78150744 sda
 253     0   78150743 dm-0
 253     1     104391 dm-1
 253     2   78043770 dm-2
total 0

cat /dev/mapper
crw------- 1 root 0  10, 63 Feb  1 22:00 control
brw------- 1 root 0 253,  0 Feb  1 22:01 nvidia_dbbddjeg
brw-rw---- 1 root 6 253,  2 Feb  1 22:01 nvidia_dbbddjegp2
brw-rw---- 1 root 6 253,  1 Feb  1 22:01 nvidia_dbbddjegp1
drwxr-xr-x 2 root 0     120 Feb  1 22:01 .
drwxrwxrwt 5 root 0    1.7K Feb  1 22:20 ..

Expected results:
list-harddrives should detect mapper devices

Additional info:
Comment 1 Jeff Burke 2009-02-02 10:45:56 EST
Created attachment 330635 [details]
ks.cfg file
Comment 2 Jeff Burke 2009-02-02 10:46:26 EST
Created attachment 330636 [details]
anaconda.log
Comment 3 Jeff Burke 2009-02-02 10:46:51 EST
Created attachment 330637 [details]
syslog
Comment 5 Joel Andres Granados 2009-04-20 11:08:30 EDT
The file that lists the dmraid sets has not changed since 2002.  Did this work in rhel5.3?
Comment 6 Jeff Burke 2009-04-20 12:54:45 EDT
Joel,
   This bug was discovered in RHEL5.3.
"Description of problem:
 RHEL5.3 fails to install when kickstart is tries to partition a system with
mapper devices."

   Did you mean to say 5.2? Here is the data from R5.2

# list-harddrives
sda 76316.5942383

# cat /proc/partitions
major minor  #blocks  name

   7     0      85516 loop0
   8     0   78150744 sda
   8     1     104391 sda1
   8     2   78043770 sda2

# ls /dev/mapper/
control
Comment 7 Joel Andres Granados 2009-04-20 13:06:41 EDT
Looking further into this issue I see that we use kudzu to get the HardDrive
list. and I also see that the HardDrive list is correctly returned.  Kudzu is
capable of probing for RAID devices with kudzu.CLASS_RAID, but it is not able
to detect the underlying devices that construct it.

Why not work with `dmraid`?  `dmraid -r` will give you the raid devices and the
set names.  And, with this information, you can further filter whatever is
returned by list-harddrives.
Comment 8 Joel Andres Granados 2009-04-20 13:10:12 EDT
I was under the impression that the what was failing was the list-harddrives.  If this is the case pls look at comment #7.  If this bug is referring to dmraid being busted on RHEL, then it is sort of a dup for 475386.  The fix that we committed for that bug, will fix this one (this has all been tested in rawhide).  Pls clarify.
Comment 9 Jeff Burke 2009-04-20 13:14:51 EDT
list-harddrives should detect mapper devices
Comment 10 Joel Andres Granados 2009-04-20 13:36:19 EDT
Its not ment to do that.  What about the work around in comment#7.
FWIW, this is not a bug this is a RFE.
Comment 11 Bill Peck 2009-04-20 13:43:30 EDT
There are many kickstart recipes in the real world which use list-harddrives to figure out the first hard drive for installation.  Now that mapper is added you've broken this.  I see this as a regression not an RFE.
Comment 12 Joel Andres Granados 2009-04-21 05:55:19 EDT
Bill:

1. We have had dmraid support since RHEL5-GOLD.  (This basically means that the raid set was detected but it was _really_ buggy)
2. list-harddrives in RHEL5-GOLD did not list the dmraid sets.
3. In RHEL5.3 we still support dmraid (the support is basically the same as in RHEL5-GOLD with some changes for raid10)
4. list-harddrives still does not list the dmraid sets.

Given 1, 2, 3 and 4. how is this a regression?  The behavior did not change.  What changed is what wanted to be done with the list-harddrives script which, to me, suggests a RFE.

This is what I saw in the tests I did in my machine.  And reading the code I really doubt that list-harddrives considered dmraid at all.  Can you direct me to the recipes you mention?  Seeing those might give me more insight on what is really happening.

Have you considered the workaround in comment #7?
Comment 13 Joel Andres Granados 2009-04-21 08:47:40 EDT
Created attachment 340511 [details]
script to list disks

This script is the work around I was talking about.  it has been tested with one type of dmraid and should work for all of them.
Comment 14 Joel Andres Granados 2009-05-08 10:36:01 EDT
I'm devel_nacking this given the existence of the workaround.
Comment 15 RHEL Product and Program Management 2009-05-08 10:46:17 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.