Bug 483647 - easytag doesn't support .oga audio files
easytag doesn't support .oga audio files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: easytag (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 13:57 EST by Dave Maley
Modified: 2009-09-12 11:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 11:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add .oga extension for EasyTAG (364 bytes, patch)
2009-09-11 09:00 EDT, James
no flags Details | Diff

  None (edit)
Description Dave Maley 2009-02-02 13:57:04 EST
Description of problem: the version of easytag included in F10 doesn't support .oga filetypes.  Support was added upstream in version 2.1.3.

Note that Sound-Juicer now defaults to extracting as .oga.


Version-Release number of selected component (if applicable):
easytag-2.1-5.fc9


How reproducible:
100%


Steps to Reproduce:
1. rip CD w/ sound-juicer
2. point easytag at resulting audio files
3.
  
Actual results:
easytag scanner doesn't see .oga files


Expected results:
ability to edit tags of extracted files


Additional info:
Comment 1 Matthias Saou 2009-04-12 12:58:03 EDT
Funny, I already reported the exact same problem against audacious a while ago :-) See bug #479120. I still don't know what the right solution is, though.
Comment 2 Dave Maley 2009-04-13 11:11:12 EDT
Based on:

http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions

... looks like either option is fine for ogg/vorbis.

Same from wikipedia:

<snip>
Previously, the .ogg file extension was used for any content distributed within Ogg, but as of 2007, the Xiph.Org Foundation requests that .ogg be used only for Vorbis due to backward compatibility concerns. The Xiph.Org Foundation decided to create a new set of file extensions and media types to describe different types of content such as .oga for audio only files, .ogv for video with or without sound (including Theora), and .ogx for applications.
</snip>
http://en.wikipedia.org/wiki/Ogg


That being said, my suggestion would be that it needs to be a Fedora-wide decision to make the change.  Changing to .oga in certain apps, and not supporting in others makes for a horrible user experience.  And since it's obvious that not all apps are ready for the change, at this point I'd recommend sticking w/ .ogg as the default, distro-wide.  Once the vast majority of apps are ready for the switch then we make the change.

This seems like a good feature[1] to target for F12, to me at least  8)


[1] https://fedoraproject.org/wiki/Features
Comment 3 Tim Jackson 2009-04-20 17:29:19 EDT
This is fixed in Easytag 2.1.4. I appreciate it's not marked as "stable" upstream, though I wonder if the maintainer has tried a test package? The last release was 2007-12-09
Comment 4 Dave Maley 2009-04-20 17:42:51 EDT
I've now had a chance to test sound-juicer in F11 beta.  It's returned
to defaulting to .ogg, and has made it easily configurable to change
to .oga if preferred.  Probably the right choice for the short-term ....

That being said I'd be willing to close this now as not-a-bug, but will defer to the pkg maintainer since, as mentioned previously, .oga support has been added to upstream easytag.
Comment 5 James 2009-09-11 09:00:13 EDT
Created attachment 360680 [details]
Patch to add .oga extension for EasyTAG

It's a fairly trivial fix, see attached patch.
Comment 6 Matthias Saou 2009-09-12 11:06:25 EDT
I've just rebuilt 2.1.6 for devel (Fedora 12) and it seems to work fine from the limited testing I've done. Since Fedora 11 defaults to creating .ogg and not .oga, this should be enough, so closing.

Note You need to log in before you can comment on or make changes to this bug.