Bug 483664 - xpdf spec file and source package fail stricter requirements of the current rpmbuild
xpdf spec file and source package fail stricter requirements of the current r...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 15:57 EST by Michal Jaegermann
Modified: 2009-03-05 12:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 12:59:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xpdf crash.patch adjusted for xpdf-3.02 (1.07 KB, patch)
2009-02-02 16:03 EST, Michal Jaegermann
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2009-02-02 15:57:58 EST
Description of problem:

$ rpmbuild -bp xpdf.spec
error: %patch without corresponding "Patch:" tag

The following minor change is required to make rpmbuild happier:

--- xpdf.spec~  2008-06-19 07:11:36.000000000 -0600
+++ xpdf.spec   2009-02-02 01:33:46.000000000 -0700
@@ -80,7 +80,7 @@ standard X fonts.
 
 %prep
 %setup -q -a 3 -a 4 -a 5 -a 6 -a 7 -a 8 -a 12 -a 13 -a 14 -a 15 -a 16
-%patch -p1
+%patch0 -p1
 %patch3 -p1 -b .ext
 %patch6 -p1 -b .core
 %patch7 -p1 -b .fonts

Also xpdf-3.01-crash.patch does not apply with --fuzz=0 as default by now due to wildly different offsets; but there are no problems with readjusting it.  All other patches do not require any changes.

Version-Release number of selected component (if applicable):
xpdf-3.02-7.fc10

How reproducible:
always
Comment 1 Michal Jaegermann 2009-02-02 16:03:44 EST
Created attachment 330676 [details]
xpdf crash.patch adjusted for xpdf-3.02
Comment 2 Tom "spot" Callaway 2009-02-11 11:38:32 EST
The spec was fixed in -8, and I rediffed the crash patch around the same time.

However, I did note that your patch was slightly different from mine, and I figured out why: there are two calls of xPath->sort() in the 3.02 code, instead of just one like 3.01 had. I saw one, you saw the other one. The new patch that will go into -10 will have both fixed.
Comment 3 Michal Jaegermann 2009-02-11 11:55:11 EST
> The new patch that will go into -10 will have both fixed.

Thanks!  You are the man. :-)
Comment 4 Tom "spot" Callaway 2009-03-05 12:59:37 EST
This has been fixed for a while, closing.

Note You need to log in before you can comment on or make changes to this bug.