Bug 483670 - Missing Dependency: portreserve is needed by package 1:cups-1.3.9-6.fc10.i386
Missing Dependency: portreserve is needed by package 1:cups-1.3.9-6.fc10.i386
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 16:41 EST by Rick Richardson
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 11:20:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2009-02-02 16:41:36 EST
Upgraded from F9 to F10.  CUPS has depsolving problems.

# yum install cups
Loaded plugins: refresh-packagekit
livna                                                    | 2.4 kB     00:00     
rpmfusion-nonfree-updates                                | 2.7 kB     00:00     
fedora                                                   | 2.4 kB     00:00     
rpmfusion-free-updates                                   | 2.7 kB     00:00     
rpmfusion-free                                           | 2.7 kB     00:00     
adobe-linux-i386                                         |  951 B     00:00     
fedora-source                                            | 1.9 kB     00:00     
rpmfusion-nonfree                                        | 2.7 kB     00:00     
updates                                                  | 2.3 kB     00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package cups.i386 1:1.3.9-6.fc10 set to be updated
--> Processing Dependency: portreserve for package: cups
--> Finished Dependency Resolution
1:cups-1.3.9-6.fc10.i386 from updates has depsolving problems
  --> Missing Dependency: portreserve is needed by package 1:cups-1.3.9-6.fc10.i386 (updates)
Error: Missing Dependency: portreserve is needed by package 1:cups-1.3.9-6.fc10.i386 (updates)

# yum install portreserve
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package portreserve available.
Nothing to do
Comment 1 Tim Waugh 2009-02-03 04:45:30 EST
..but portreserve *is* available for Fedora 10:

http://koji.fedoraproject.org/koji/buildinfo?buildID=66422

portreserve-0.0.3-2.fc10 is tagged f10-final.

What does 'yum repolist' say?
Comment 2 Rick Richardson 2009-02-03 07:22:19 EST
$ yum repolist
Loaded plugins: refresh-packagekit
repo id                   repo name                               status
adobe-linux-i386          Adobe Systems Incorporated              enabled:    17
fedora                    Fedora 10 - i386                        enabled: 9,897
livna                     rpm.livna.org for 10 - i386             enabled:     3
rpmfusion-free            RPM Fusion for Fedora 10 - Free         enabled:   324
rpmfusion-free-updates    RPM Fusion for Fedora 10 - Free - Updat enabled:   351
rpmfusion-nonfree         RPM Fusion for Fedora 10 - Nonfree      enabled:   142
rpmfusion-nonfree-updates RPM Fusion for Fedora 10 - Nonfree - Up enabled:   237
updates                   Fedora 10 - i386 - Updates              enabled: 3,104
repolist: 14,075
Comment 3 Rick Richardson 2009-02-03 08:58:53 EST
Ah hah.  "yum clean all" does the trick:

$ root yum clean all
Loaded plugins: refresh-packagekit
Cleaning up Everything

$ root yum makecache
Loaded plugins: refresh-packagekit
livna                                                    | 2.4 kB     00:00     
livna/filelists_db                                       | 1.3 kB     00:00     
livna/other_db                                           | 1.0 kB     00:00     
livna/group_gz                                           |  451 B     00:00     
livna/primary_db                                         | 2.7 kB     00:00     
rpmfusion-nonfree-updates                                | 2.7 kB     00:00     
rpmfusion-nonfree-updates/filelists_db                   |  35 kB     00:00     
rpmfusion-nonfree-updates/other_db                       |  39 kB     00:00     
rpmfusion-nonfree-updates/group_gz                       | 1.0 kB     00:00     
rpmfusion-nonfree-updates/primary_db                     |  76 kB     00:00     
fedora                                                   | 2.8 kB     00:00     
fedora/filelists_db                                      |  11 MB     00:07     
fedora/other_db                                          | 3.6 MB     00:02     
fedora/group_gz                                          | 335 kB     00:00     
fedora/primary_db                                        | 6.6 MB     00:06     
rpmfusion-free-updates                                   | 2.7 kB     00:00     
rpmfusion-free-updates/filelists_db                      |  66 kB     00:00     
rpmfusion-free-updates/other_db                          |  58 kB     00:00     
rpmfusion-free-updates/group_gz                          | 1.4 kB     00:00     
rpmfusion-free-updates/primary_db                        | 149 kB     00:00     
rpmfusion-free                                           | 2.7 kB     00:00     
rpmfusion-free/filelists_db                              | 269 kB     00:00     
rpmfusion-free/other_db                                  |  76 kB     00:00     
rpmfusion-free/group_gz                                  | 1.4 kB     00:00     
rpmfusion-free/primary_db                                | 212 kB     00:00     
adobe-linux-i386                                         |  951 B     00:00     
adobe-linux-i386/filelists                               | 173 kB     00:00     
adobe-linux-i386/other                                   | 1.9 kB     00:00     
adobe-linux-i386/primary                                 |  10 kB     00:00     
rpmfusion-nonfree                                        | 2.7 kB     00:00     
rpmfusion-nonfree/filelists_db                           |  41 kB     00:00     
rpmfusion-nonfree/other_db                               |  36 kB     00:00     
rpmfusion-nonfree/group_gz                               |  937 B     00:00     
rpmfusion-nonfree/primary_db                             |  68 kB     00:00     
updates                                                  | 2.3 kB     00:00     
updates/filelists_db                                     | 4.6 MB     00:04     
updates/updateinfo                                       | 331 kB     00:00     
updates/other_db                                         | 7.8 MB     00:08     
updates/group                                            | 1.4 MB     00:02     
updates/primary_db                                       | 2.1 MB     00:03     
adobe-linux-i386                                                          17/17
adobe-linux-i386                                                          17/17
adobe-linux-i386                                                          17/17
Metadata Cache Created

$ yum repolist
Loaded plugins: refresh-packagekit
repo id                   repo name                              status
adobe-linux-i386          Adobe Systems Incorporated             enabled:     17
fedora                    Fedora 10 - i386                       enabled: 11,416
livna                     rpm.livna.org for 10 - i386            enabled:      3
rpmfusion-free            RPM Fusion for Fedora 10 - Free        enabled:    324
rpmfusion-free-updates    RPM Fusion for Fedora 10 - Free - Upda enabled:    351
rpmfusion-nonfree         RPM Fusion for Fedora 10 - Nonfree     enabled:    142
rpmfusion-nonfree-updates RPM Fusion for Fedora 10 - Nonfree - U enabled:    237
updates                   Fedora 10 - i386 - Updates             enabled:  3,104
repolist: 15,594

$ root yum install portreserve
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package portreserve.i386 0:0.0.3-2.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch          Version               Repository       Size
================================================================================
Installing:
 portreserve          i386          0.0.3-2.fc10          fedora           22 k

Transaction Summary
================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 22 k
Is this ok [y/N]: y
Downloading Packages:
portreserve-0.0.3-2.fc10.i386.rpm                        |  22 kB     00:00     
============================== Entering rpm code ===============================
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : portreserve                                              1/1 
=============================== Leaving rpm code ===============================

Installed:
  portreserve.i386 0:0.0.3-2.fc10                                               

Complete!
$
Comment 4 Tim Waugh 2009-02-03 09:02:53 EST
Reassigning to yum.
Comment 5 seth vidal 2009-02-03 10:14:55 EST
Is there a bug here?
Comment 6 Rick Richardson 2009-02-03 10:23:17 EST
During update from F9 to F10.
Comment 7 James Antill 2009-02-03 11:20:20 EST
first repolist:

fedora                    Fedora 10 - i386                        enabled:
9,897

...second repolist:

fedora                    Fedora 10 - i386                       enabled:
11,416

...what this means is that in the first repolist fedora == Fedora 9, after doing the cache update it then changed to Fedora 10 and everything was happy.
 Anaconda is supposed to clear the cache if you do the update with it/preupgrade ... there isn't much yum can do here.
Comment 8 Rick Richardson 2009-02-03 11:38:13 EST
I did the update from the Fedora 10 DVD.  So, anaconda is wrong, then, because it didn't clear the cache.

Note You need to log in before you can comment on or make changes to this bug.