Bug 483672 - I cannot mount shares
I cannot mount shares
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 17:12 EST by antonio montagnani
Modified: 2009-02-14 15:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-14 04:41:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
samba log with debug level 10 (1.85 KB, text/plain)
2009-02-04 03:32 EST, antonio montagnani
no flags Details
Samba.conf file (9.65 KB, application/x-extension-conf)
2009-02-04 03:33 EST, antonio montagnani
no flags Details
New samba.log (50.49 KB, application/octet-stream)
2009-02-04 09:17 EST, antonio montagnani
no flags Details
copy of screen (63.69 KB, image/jpeg)
2009-02-05 16:44 EST, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2009-02-02 17:12:54 EST
Description of problem:
when I  open Resources/Network/Windows Network/CASA (that is my
computer) I get the windows with shared folders, when I click on any
of them I get
Mount of share failed

and in var/log/samba a message:

[2009/01/31 08:38:53,  0] smbd/service.c:make_connection_snum(1152)
 '/home/antonio/Radioamatori' does not exist or permission denied
when connecting to [Radioamatori] Error was Permission denied

My F11 is a fully updated system created by a running F10 and using
rawhide repository. (early user of F11, I think that up to now there
is no installation media available)



Version-Release number of selected component (if applicable):
samba-3.2.5-0.23.fc11.i386

How reproducible:
always

Steps to Reproduce:
1.Open Resources/Network/Windows network
2.Click on a network computer
3.Click on any shared folder
  
Actual results:
no mount

Expected results:
it should work

Additional info:
Comment 1 Simo Sorce 2009-02-03 15:38:17 EST
Antonio, the samba release in rawhide should be 3.3.0, can you check the machine is really fully updated ?

Simo.
Comment 2 antonio montagnani 2009-02-03 16:10:43 EST
rpm -qa samba
samba-3.2.5-0.23.fc11.i386
[antonio@Casa ~]$ su
Password: 
[root@Casa antonio]# yum update samba
Plugin caricati:dellsysidplugin2, refresh-packagekit, upgrade-helper
Impostazione Processo di Aggiornamento
Nessun pacchetto marcato per l'aggiornamento


funny as it means that yum update doesn't find any update for samba!!

Shall I file another bug against yum???? :-)
Comment 3 antonio montagnani 2009-02-03 16:15:05 EST
and at least in koij I have not seen any updates to reported version of samba!!!

Antonio
Comment 4 Simo Sorce 2009-02-03 19:01:22 EST
Ooops my bad, I thought Guenther had already built it.

Can you post smb.conf and a level 10 log that shows the problem ?
Comment 5 antonio montagnani 2009-02-04 03:32:55 EST
Created attachment 330835 [details]
samba log with debug level 10

I connected to my windows shares on same machine
Comment 6 antonio montagnani 2009-02-04 03:33:52 EST
Created attachment 330836 [details]
Samba.conf file
Comment 7 Simo Sorce 2009-02-04 08:58:26 EST
(In reply to comment #5)
> Created an attachment (id=330835) [details]
> samba log with debug level 10
> 
> I connected to my windows shares on same machine

The file has been cut too much, I need to see a bit more than just the error number
Comment 8 antonio montagnani 2009-02-04 09:17:20 EST
Created attachment 330865 [details]
New samba.log

new samba.log
Comment 9 Simo Sorce 2009-02-04 09:39:14 EST
The only error I can see in this snipped is NT_STATUS_WRONG_PASSWORD, are you sue the password is correct?
I also see an error referring to a bad path at the start of the file, but you cut the log there and I can't see what leads to that error.
Comment 10 antonio montagnani 2009-02-04 10:18:05 EST
I have not been asked for any password, no prompt appeared on my screen!!!

I will re-rerun same test tonight if you like, in order to have a complete log maybe that cutting & pasting is not my preferred job ;-)

Any other test that I could run to help?? if I am not wrong, as this box is a F10 updated to F11 by yumming, when it was a F10 but also at beginning of F11 era, I could jump to any windows shared folder (and I have not changed anything in my setup)

Tnx anyway
Comment 11 antonio montagnani 2009-02-04 11:17:34 EST
 I forgot to report the output of command smbclient with no password:

smbclient -L //AcerF10
Enter antonio's password: 
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.2.7-0.25.fc10]

	Sharename       Type      Comment
	---------       ----      -------
	Documenti_personali Disk      
	Musica          Disk      
	IPC$            IPC       IPC Service (AcerSamba Version 3.2.7-0.25.fc10)
	ML-1610         Printer   SamsungLaser
	HP-P1005suCeleron Printer   HP LaserJet P1005 su Celeron
	HP-LaserJet-P1005 Printer   Hewlett-Packard HP LaserJet P1005
	HP-LaserJet-1005suVaio Printer   HP LaserJet 1005
	Cups-PDF        Printer   Cups-PDF
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.2.7-0.25.fc10]

	Server               Comment
	---------            -------
	ACERF10              AcerSamba Version 3.2.7-0.25.fc10
	PC-HPCONTEC          

	Workgroup            Master
	---------            -------
	WORKGROUP            PC-HPCONTEC


I assume that I should be able to surf Musica and Documenti_Personali, shouldn't I??
Comment 12 antonio montagnani 2009-02-05 16:43:34 EST
I updated to samba-3.3.0-0.25.fc11.i386.
No improvement.
I attach a copy of the screen
Comment 13 antonio montagnani 2009-02-05 16:44:59 EST
Created attachment 331058 [details]
copy of screen

screen copy of what I run...
Comment 14 antonio montagnani 2009-02-05 16:58:54 EST
log of saqmba connection

[2009/02/05 22:50:23,  0] smbd/service.c:make_connection_snum(1065)
  '/home/antonio/Documentiidentita' does not exist or permission denied when connecting to [Documentiidentita] Error was Permission denied
[2009/02/05 22:50:25,  0] smbd/service.c:make_connection_snum(1065)
  '/home/antonio/Radioamatori' does not exist or permission denied when connecting to [Radioamatori] Error was Permission denied

I don't know if it is my mistake or a bug...
Comment 15 Simo Sorce 2009-02-14 11:10:56 EST
Antonio,
did you close the bug because you found the problem ?
If so can you share what was it ?
Comment 16 antonio montagnani 2009-02-14 12:37:59 EST
Simo,

I closed the bug as I think that I have to study  how Samba works, even it is not easy, two many available option!! At least I can connect  as user, not sure that I can work if share option is activated.

I find very strange (as user) that sharing a printer is really easy from/to Windows and from/to Fedora, but sharing a folder is not as easy.
I have to find a really updated howto with easy examples (that are the most common ones..).

Do you think that it is worth re-opening it until we can carry out more tests???

please note, that as nobody joined this bug, I thought that it was my fault, not Samba
Comment 17 Simo Sorce 2009-02-14 15:15:08 EST
Permission problems are generally always configuration problems and not samba bugs.
I am ok with keeping this closed.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.